Ubuntu 16.04安装RabbitVCS替代TortoiseSVN/TortoiseGit

RabbitVCS官网:http://www.rabbitvcs.org/easonjim

1、添加PPA源

sudo add-apt-repository ppa:rabbitvcs/ppa

如果导入密钥失败,则在/etc/apt/sources.list文件中加入下面的文字(signing key=1024R/34EF4A35):

deb http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu **DISTRIBUTION** main

提示:一般在16.04的系统中不会不成功。

2、执行更新

sudo apt-get update

3、安装依赖库

sudo apt-get install python-nautilus python-configobj python-gtk2 python-glade2 python-svn python-dbus python-dulwich subversion meld

4、安装RabbitVCS

sudo apt-get install rabbitvcs-cli rabbitvcs-core rabbitvcs-gedit rabbitvcs-nautilus

5、如果在文件夹上鼠标右键没有显示RabbitVCS菜单,则依次执行下面命令后重试。

nautilus -q
nautilus

或者重新启动电脑。

参考:

http://wiki.rabbitvcs.org/wiki/install/ubuntu

http://www.linuxdiyf.com/linux/29153.html

时间: 08-13

Ubuntu 16.04安装RabbitVCS替代TortoiseSVN/TortoiseGit的相关文章

Ubuntu 16.04安装SecureCRT替代XShell

XShell应该是最强大的,在Ubuntu下只有SecureCRT能实现跨平台(Linux/Windows/Mac).还可以使用PuTTY. 一.下载: 登录官网,不过要注册账号密码. 历史版本:https://www.vandyke.com/download/prevreleases.html 最新版本:https://www.vandyke.com/download/securecrt/download.html(截止到今天为8.1.4) 二.安装: sudo dpkg -i scrt-8.

Ubuntu 16.04安装GIMP替代PS

GIMP虽然不能完全替代PS,但是也能弥补一下. 系统默认源中已经包含了GIMP,不需要使用PPA这些. 安装: sudo apt-get install gimp 启动: 通过Dash搜索GIMP即可.或者命令行输入GIMP也行. 参考: https://www.gimp.org/downloads/

Ubuntu 16.04安装Kdbg替代Insight实现汇编的调试

Insight已经不能使用APT进行安装,且如果使用源码安装时需要修改.所以只能放弃,转投使用Kdbg. 安装: sudo apt-get install kdbg 使用: nasm -f elf64 -g -F stabs sandbox.asm -o sandbox.o ld -o sandbox sandbox.o kdbg sanbox

Ubuntu 16.04安装uGet替代迅雷,并在Chrome中设置为默认下载器

uGet是采用aria2作为下载后端,所以两个软件都必须同时安装. 1.安装uGet sudo add-apt-repository ppa:plushuang-tw/uget-stable sudo apt-get update sudo apt-get install uget 2.安装aria2 sudo add-apt-repository ppa:t-tujikawa/ppa sudo apt-get update sudo apt-get install aria2 3.配置uGet

Ubuntu 16.04安装QQ国际版图文详细教程

      因工作需要,我安装了Ubuntu 16.04,但是工作上的很多事情需要QQ联系,然而在Ubuntu上的WebQQ很是不好用,于是在网上搜索了好多个Linux版本的QQ,然而不是功能不全,就是界面丑到爆,要么就是不稳定:最后,找到了个人认为最好用的QQ-WineQQ国际版. 说明:一开始,我在Ubuntu 16.04下安装的QQ版本是Wineqq2013SP6-20140102-Longene,但后来发现这个版本QQ在linux下问题很多,比如不能 用键盘输入密码,QQ表情使用失灵,有

Ubuntu 16.04 安装 Kodi v17 “Krypton” Alpha 2

Ubuntu 16.04 安装 Kodi v17 “Krypton” Alpha 2:sudo add-apt-repository ppa:team-xbmc/xbmc-nightlysudo apt-get updatesudo apt-get install kodi 安装插件编码sudo apt-get install kodi-audioencoder-* kodi-pvr-* 移除 Kodi v17sudo apt-get remove kodi* 本文永久更新地址:http://w

Ubuntu 16.04安装QtCharts时报错:'qtConfig' is not a recognized test function.

错误: 'qtConfig' is not a recognized test function. 解决方法: 其实5.9分支的版本有问题,转成5.7分支即可. git clone https://github.com/qtproject/qtcharts.git cd qtcharts git checkout 5.7 qmake make sudo make install 参考: http://php.wekeepcoding.com/article/10792742/Cross-comp

Ubuntu 16.04 安装 Docker

Ubuntu 16.04 安装 docker 是一件很麻烦的事情,但鉴于 docker 的各种优点,还是忍了.参考docker官网. 1.选择国内的云服务商,这里选择阿里云为例 curl -sSL http://acs-public-mirror.oss-cn-hangzhou.aliyuncs.com/docker-engine/internet | sh - 2.安装所需要的包 sudo apt-get install linux-image-extra-$(uname -r) linux-

Ubuntu 16.04 安装 QT Create 5.3.1

Ubuntu 16.04 安装 QT Create 5.3.1 (qt-opensource-linux-x86-5.3.1.run)后新建一个 QT Quick 的工程.直接编译,出现如下错误的提示: qt cannot find lgl 刚开始按网上的方法,需要修改依赖库的版本,但依赖是一层接着一层,唉...... 最后找到如下的解决方法(参考如下链接: http://blog.csdn.net/u012175418/article/details/52078291): [email pro