1在路由器上配置 Telnet

实验 在路由器上配置 Telnet

【实验名称】

在路由器上配置 Telnet。

【实验目的】

掌握如何在路由器上配置 Telnet,以实现路由器的远程登录访问。

【背景描述】

路由器用于连接多个子网时,通常放置位置都相距较远,察看和修改配置都比较麻烦,

此时如果可以远程登录到路由器上进行操作,将能够大大降低管理员的工作量。

【需求分析】

需要掌握如何配置路由器的密码, 如何配置 Telnet 服务, 以及如何通过 Telnet 远程登录

路由器进行操作的方法。

【实验拓扑】

图 6-2 实验拓扑图

【实验设备】

路由器(带串口) 2 台

V.35 DCE/DTE 线缆 1 对

【预备知识】

路由器的工作原理和基本配置方法

【实验原理】

将两台路由器通过串口,以 V.35 DTE/DCE 电缆连接在一起,分别配置 Telnet,可以互

相以 Telnet 方式登录对方。

路由器提供广域网接口(serial 高速同步串口) ,使用 V.35 线缆连接广域网接口链路。

在广域网连接时一端为 DCE(数据通信设备) ,一端为 DTE(数据终端设备) 。要求必须在

DCE 端配置时钟频率(clock rate)才能保证链路的连通。

【实验步骤】

第一步:配置路由器的名称、接口 IP  地址和时钟

R3740#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3740(config)#hostname RouterA

!配置路由器的名称

RouterA(config)#interface serial 4/0

!进入串口的接口配置模式

RouterA(config-if)#clock rate 512000

!设置 DCE 端的时钟频率

RouterA(config-if)#ip address 192.168.1.1 255.255.255.0

!配置接口 IP 地址

RouterA(config-if)#no shutdown

!启用端口

RouterA(config-if)#exit

R3740#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3740(config)#hostname RouterB

RouterB(config)#interface serial 4/0

RouterB(config-if)#ip address 192.168.1.2 255.255.255.0

RouterB(config-if)#no shutdown

RouterB(config-if)#exit

第二步:配置 Telnet

RouterA(config)#enable password ruijie

!配置路由器的特权模式密码

RouterA(config)#line vty 0 4

!进入线程配置模式

RouterA(config-line)#password star

!配置 Telnet 密码

RouterA(config-line)#login

!设置 Telnet 登录时进行身份验证

RouterA(config-line)#end

RouterB(config)#enable password ruijie

RouterB(config)#line vty 0 4

RouterB(config-line)#password star

RouterB(config-line)#login

RouterB(config-line)#end

第三步:测试网络连通性,以 Telnet  方式登录路由器

RouterB#ping 192.168.1.1

Sending 5, 100-byte ICMP Echoes to 192.168.1.1, timeout is 2 seconds:

< press Ctrl+C to break >

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/10 ms

RouterB#telnet 192.168.1.1

Trying 192.168.1.1, 23...

User Access Verification

Password:

!提示输入 Telnet 密码,此处输入 ruijie

RouterA>en

Password:

!提示输入特权模式密码,此处输入 star

RouterA#en

!远程登录路由器 A,可进行配置

RouterA#

RouterA#conf t

Enter configuration commands, one per line. End with CNTL/Z.

RouterA(config)#exit

RouterA#

RouterA#

RouterA#exit

!使用 exit 命令退出 Telnet 登录

RouterB#

RouterA#ping 192.168.1.2

Sending 5, 100-byte ICMP Echoes to 192.168.1.2, timeout is 2 seconds:

< press Ctrl+C to break >

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms

RouterA#telnet 192.168.1.2

Trying 192.168.1.2, 23...

User Access Verification

Password:

RouterB>en

Password:

RouterB#

RouterB#conf t

Enter configuration commands, one per line. End with CNTL/Z.

RouterB(config)#exit

RouterB#

RouterB#exit

RouterA#

【注意事项】

1、如果两台路由器通过串口直接互连,则必须在其中一端设置时钟频率(DCE) 。

2、如果没有配置 Telnet 密码,则登录时会提示“Password required, but none set” 。

3、 如果没有配置 enable 密码,则远程登录到路由器上后不能进入特权模式,提示

“Password required, but none set” 。

【参考配置】

RouterA#show running-config

Building configuration...

Current configuration : 582 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 21:16:17 CST 2007 -ubu1server)

hostname RouterA

!

!

enable password 7 035122110c3706

!

interface serial 4/0

ip address 192.168.1.1 255.255.255.0

clock rate 512000

!

interface serial 4/1

clock rate 64000

!

interface GigabitEthernet 0/0

duplex auto

speed auto

!

interface GigabitEthernet 0/1

duplex auto

speed auto

!

!

line con 0

line aux 0

line vty 0 4

login

password 7 0133574225

!

end

RouterB#show running-config

Building configuration...

Current configuration : 562 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 21:16:17 CST 2007 -ubu1server)

hostname RouterB

!

!

enable password 7 0251563e120f3b

!

interface serial 4/0

ip address 192.168.1.2 255.255.255.0

!

interface serial 4/1

clock rate 64000

!

interface GigabitEthernet 0/0

duplex auto

speed auto

!

interface GigabitEthernet 0/1

duplex auto

speed auto

!

line con 0

line aux 0

line vty 0 4

login

password 7 0059344251

!

end

时间: 09-19

1在路由器上配置 Telnet的相关文章

在路由器上配置Telnet

路由器用于连接多个子网时,通常放置位置都相距较远,察看和修改配置都比较麻烦, 此时如果可以远程登录到路由器上进行操作,将能够大大降低管理员的工作量.那么我们就要学会如何配置路由的Telnet服务,以及如何通过Telnet登录到路由器进行操作的方法. 实验设备:路由器(带串口),V.35DCE/DTE线缆,pc机. 实验原理:将两台路由器通过串口,以 V.35 DTE/DCE 电缆连接在一起,分别配置 Telnet,可以互 相以 Telnet 方式登录对方. 路由器提供广域网接口(serial 高

Cisco路由器上配置L2L IPSec VPN实例

实例一 Cisco路由器实现L2L IPSecVPN(--自明教教主) 拓扑图: 描述: 通讯点:PC1的1.1.1.1和Site2的2.2.2.2 加密点:Site1的202.100.1.1和Site2的61.128.1.1 要求:通信点间通过IPSEC VPN实现安全通信 PC1: 基础配置: en config t no ip domain-lookup line vty 0 15 logging synchronous exec-timeout 0 0 password cisco ex

实验一:配置路由器/交换机的Telnet登录

[实验名称] 在路由器上配置 Telnet. [实验目的] 掌握如何在路由器上配置 Telnet,以实现路由器的远程登录访问. [背景描述] 路由器用于连接多个子网时,通常放置位置都相距较远,察看和修改配置都比较麻烦, 此时如果可以远程登录到路由器上进行操作,将能够大大降低管理员的工作量. [需求分析] 需要掌握如何配置路由器的密码, 如何配置 Telnet 服务, 以及如何通过 Telnet 远程登录 路由器进行操作的方法. [实验拓扑] [实验设备] 路由器(带串口) 2 台 V.35 DC

在路由器/交换机上配置Telnet

实验目的: 学习如何在交换机/路由器上启用Telnet,实现通过Telnet远程访问交换机/路由器. 实验仪器: 二层交换机一台/三层交换机一台/路由器一台 实验原理:在两台交换机上配置VLAN 1的IP地址,用双绞线将两台交换机的F0/1接口连接起来,分别配置Telnet,然后就可以通过Telnet的方式登录另一台交换机. 实验步骤:1.在路由器上配置主机名,设置Ip地址 激活2.在路由器上配置Telnetenable password 0 123<配置enable的密码为123>line

配置路由器/交换机的Telnet登入

[实验名称] 在路由器上配置Telnet. [实验目的] 掌握如何在路由器上配置 Telnet,以实现路由器的远程登录访问. [背景描述] 路由器用于连接多个子网时,通常放置位置都相距较远,察看和修改配置都比较麻烦, 此时如果可以远程登录到路由器上进行操作,将能够大大降低管理员的工作量. [需求分析] 需要掌握如何配置路由器的密码,如何配置 Telnet 服务,以及如何通过 Telnet 远程登录 路由器进行操作的方法. [实验设备] 路由器(带串口)     2台 V.35 DCE/DTE 线

Cisco-HSRP 热备份路由器协议-配置实例

同样的,首先做一些理论的扫盲.最起码要知道自己在配什么东西才行. 简介 HSRP(Hot StandbyRouter Protocol 热备份路由器协议)是Cisco的专有协议.HSRP把多台路由器组成一个"热备份组",形成一个虚拟路由器.这个组内只有一个路由器是Active(活动)的,并由它来转发数据包,如果活动路由器发生了故障,备份路由器将成为活动路由器.从网络内的主机来看,网关并没有改变. HSRP的工作过程 HSRP路由器利用Hello包来互相监听各自的存在.当路由器长时间没有

在路由器配置telnet

配置路由器名称,接口ip地址 Router(config)#hostname ***(改路由器名字) Router(config-if)#ip address 172.28.15.21 172.28.15.254(配置接口ip地址) Router(config-if)#no shutdown (开启该端口) Router(config-if)#sh ip int b(查看端口的状态是否为up,地址等) 配置telnet RouterA(config)#enable password ruijie

配置路由器/交换机的Telnet登录

[实验名称] [实验目的] 学习如何在交换机上启用Telnet,实现通过Telnet远程访问交换机. [背景描述] 企业园区网覆盖范围较大时,交换机会分别放置在不同的地点,如果每次配置交换机都到交换机所在地点现场配置,管理员的工作量会很大.这时可以在交换机上进行Telnent配置,以后再需要配置交换机时,管理员可以远程以Telnet方式登录配置. [需求分析] 需要掌握如何配置交换机的密码,以及如何配置Telnet,掌握以Telnet的方式远程访问交换机需要掌握如何配置交换机的密码,以及如何配置

华为路由器配置 Telnet

最近比较黑仔,什么事都不想干,但又要找些事来自己,就乱搞. Telnet 其实配置简单,也就几条命令,只是无聊,所以玩下吧了 配置IP : [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip add 192.168.12.1 24 -------------------------------------------------- [R2]int g0/0/0 [R2-GigabitEthernet0/0/0]ip add 192.168.12.2 24 ---