python3.5.0+ipython-5.0.0安装时遇到的问题

环境:Centos6.5,新安装的系统

1.第一次安装时,未安装任何依赖包,安装到最后有一个告警:Ignoring ensurepip failure: pip 7.1.2 requires SSL/TLS,未在意

2.安装ipython,安装完成后进入ipython提示缺少traitlets

3.安装pip模块,安装过程中提示需要setuptools 模块

4.安装setuptools安装包,提示依赖zlib,安装zlib-devel,安装后还是不行。

5.注意到安装python最后提示pip未安装成功,缺少SSL/TLS,遂删除python安装的目录,先安装openssl-devel包,后再次安装python,最后提示:

Installing collected packages: setuptools, pip
Successfully installed pip-7.1.2 setuptools-18.2

6.重复第二部的步骤,然后就直接可用pip安装缺少的模块。

完整安装步骤:

yum -y install openssl-devel
tar xf Python-3.5.0.tgz
cd Python-3.5.0/
./configure --prefix=/usr/local/python3.5
make -j 4 && make install  #因是4核CPU,故这里使用4,这里适自己情况而定
echo "export PATH=/usr/local/python3.5/bin:\$PATH" > /etc/profile.d/python3.5.sh
. /etc/profile.d/python3.5.sh
tar xf ipython-5.0.0.tar.gz
cd ipython-5.0.0/
python3.5 setup.py install
pip3.5 install traitlet
pip3.5 install pygments
pip3.5 install pexpect
pip3.5 install pickleshare
pip3.5 install prompt_toolkit
pip3.5 install simplegeneric

注:

更新pip版本:# pip3.5 install -U pip

时间: 08-02

python3.5.0+ipython-5.0.0安装时遇到的问题的相关文章

PHPRAP v1.0.8 版本发布,安装时数据库不存在自动创建

PHPRAP,是一个PHP轻量级开源API接口文档管理系统,致力于减少前后端沟通成本,提高团队协作开发效率,打造PHP版的RAP. PHPRAP已被评选为码云最有价值开源项目 更新记录 [修复]修复在虚拟主机下安装失败的BUG [修复]修复程序异常时页面空白的BUG [修复]修复上传建表sql文件时初始进度百分比错误的BUG [优化]安装步骤二中数据库名不存在自动创建 [新增]管理后台新增是否开启登录和注册验证码开关 [新增]安装步骤一中新增curl扩展是否安装的检测 特性 部署简单 提供傻瓜式

Centos7 安装Python3.6.5 及 安装ipython 6.1.0

一.centos7 安装 Python3.6.5教程 1.在安装Python之前,需要先安装一些后面遇到的依赖问题(如果有依赖问题,按照提示安装): yum -y install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel     yum install xz gcc zlib 

CentOS6.5 Python 2.7.11+IPython 4.2.0安装

1.下载Python2.7.11 https://www.python.org/downloads/release/python-2711/ 解决一个依赖关系 yum install readline-devel 解压.安装 tar xvf Python-2.7.11.tar.xz cd Python-2.7.11 ./configure --prefix=/usr/local/python27 make&&make install 2.下载ipython https://pypi.pyt

Ubuntu 14.04下搭建Python3.4 + PyQt5.3.2 + Eric6.0开发平台

Ubuntu 14.04下搭建Python3.4 + PyQt5.3.2 + Eric6.0开发平台 分类: Linux Ubuntu Oracle 2014-10-14 14:49 3613人阅读 评论(13) 收藏 举报 Ubuntu Python SIP PyQt5 Eric6 目录(?)[+] 引言 找 了很多Python GUI工具集,还是觉得PyQt比较理想,功能强大跨平台,还支持界面设计器.花一天时间折腾了Ubuntu14.04(32位)+ Python3.4 + Qt5.3.2

anaconda环境中---py2.7下安装tf1.0 + py3.5下安装tf1.5

anaconda环境中---py2.7下安装tf1.0 + py3.5下安装tf1.5 @wp20181030 环境:ubuntu18.04, anaconda2, ubuntu系统下事先安装了python2.7.15(默认)和python3.6.5, ..... 这里,利用anaconda 2(自行先安装好),在建立py2.7 和 py3.5的环境,分别安装tf1.0 和 tf1.5,具体的如下: 情况一:py2.7下安装tf1.0. #(1)新建一个test_py2环境[py2+tf1.0]

Ubuntu 18.04 nvidia driver 390.48 安装 TensorFlow 1.12.0 和 PyTorch 1.0.0 详细教程

最近要在个人台式机上搭建TensorFlow和PyTorch运行环境,期间遇到了一些问题.这里就把解决的过程记录下来,同时也可以作为安装上述环境的过程记录. 如果没有遇到类似的问题,想直接从零安装上述两个包的运行环境的,请直接阅读第三部分. 一.硬件和环境配置: 1)操作系统:Ubuntu 18.04: 2)NVIDIA Driver Version :390.48:(可通过nvidia-smi命令查到) 3)GPU:GTX 1080: (可通过nvidia-smi命令查到) 4)已安装CUDA

Superset 0.28三奏曲——安装、集成ECharts和汉化

1 环境和版本 操作系统:CentOS Linux release 7.5.1804 (Core) python版本:3.6.4(直接安装Anaconda即可) 2 一奏曲--Superset安装(0.28版本) Superset 0.22版本的看板中存在很多bug,比如:多个类型一样的图表加入到看板中,只有第一个图可以显示,其他同类型的图均显示不出.在最新版本中不存在,故建议安装最新版本Superset 0.28. (1)万事开头难.首先咱们得要先安装Anaconda,因为接下来需要用到pip

《大大李带你玩转XenServer 7.0系列》 一、安装XenServer 7.0

2016年5月24号Citrix低调发布了XenServer 7.0正式版,7.0同6.5一样仍然提供免费的开源版本,同时也保持了两个商用版本 Standard 和 Enterprise: Standard Edition 是入门级商用产品,如果希望使用强大的高性能虚拟化平台,但不需要 Enterprise Edition 提供的高级功能,而同时仍希望获得全面的 Citrix 支持和维护保障,本版本提供的一系列功能可以满足此类客户的需求. Enterprise Edition 是全功能高级版本,

第十二节 VMware View 6.0 菜鸟入门 部署和安装RDS服务器

第十二节 VMware View 6.0 菜鸟入门 部署和安装RDS服务器