关于 3750 vlan 设置

>#config

int vlan 1    
  
  
    
\\进入vlan1,vlan 1
是默认存在的,你不能改名字,也不能删除.你也可以建个新的vlan做你的管理口.

ip add 192.168.254.254 255.255.255.0 \\设置vlan 1
的ip

no shut    
   \\启用vlan1

exit

以下的你要配置4遍,因为你有4个vlan:

vlan 10    
   \\创建vlan 10

name xxx \\给vlan 10命名

no shut    
   \\启用

exit

int vlan 10    
  
  
    
\\进入vlan 10

ip add 192.168.1.1 255.255.255.0 
  
   \\设置vlan 10的IP

no shut    
  
  
    
\\启用,一下省略了

exit

int range g0/2-3 
  
  
  
    
\\进入端口2-3,range是在设置多端口的时候才用,配置一个端口的时候不需要的.如果你的3750的都是千兆口,那就是g0/2-3,如果是百兆口的,就是Fa0/2-3了.

switchport access vlan 10 
  
  
  
    
\\设置端口接收vlan10的信息.

switchport mode access 
  
  
  
    
\\设置端口模式

no shut

exit

vlan 20

name xxx

no shut

exit

int vlan 20

ip add 192.168.2.1 255.255.255.0

no shut

exit

int range g0/6-10

switchport access vlan 20

switchport mode access

no shut

exit

vlan 30

name xxx

no shut

exit

int vlan 30

ip add 192.168.3.1 255.255.255.0

no shut

exit

int g0/11

switchport access vlan 20

switchport mode access

no shut

exit

vlan 40

name xxx

no shut

exit

int vlan 40

ip add 192.168.4.1 255.255.255.0

no shut

exit

int g12

switchport access vlan 40

switchport mode access

no shut

exit

ip route 0.0.0.0 0.0.0.0 192.168.254.1 
  
   \\设置默认路由:

ip routing    
   \\开启路由功能
到这里就差不多了,不过还要设置一个trunk口,看你分的端口,就放在1口吧.

还在config配置模式下:

int g0/1

switchport mode trunk 
  
  
  
    
\\设置端口1为trunk模式.

switchport trunk allow vlan all 
  
  
  
    
\\设置端口1为允许所有vlan通过


switchport
trunk enca
dot1q  \\
设置treunk的通信协议,dto1q802.1q,用这个的话,以后还可以连其他厂商的设备!

no shut

exit

好了,然后还要设置个dhcp,

还是在config配置模式下:

ip dhcp excluded-address 192.168.1.1 
  
  
  
    
\\设置sdhp不在自动分配之内的地址

ip dhcp excluded-address 192.168.1.254 
  
  
  
    
\\设置sdhp不在自动分配之内的地址

ip dhcp excluded-address 192.168.2.1

ip dhcp excluded-address 192.168.2.254

ip dhcp excluded-address 192.168.3.1

ip dhcp excluded-address 192.168.3.254

ip dhcp excluded-address 192.168.4.1

ip dhcp excluded-address 192.168.4.254

ip dhcp pool vlan1 
  
  
  
    
\\命名dhcp的地址池名称

network 192.168.1.0
255.255.255.0 
  
   \\设置dhcp的网络

default-router
192.168.1.1    
  
  
    
\\设置dhcp的默认网关,都是vlan的ip.

dns-server 202.96.209.5
202.96.209.6 \\设置dhcp获取的ip的dns,如果内网有dns服务器的话,就改成自己的dns服务器的ip

lease 3 
  
  
  
    
\\设置dhcp的租期,千万不要设置大的时间,否则有新的机器加入这个vlan,就没有IP给再加入这个vlan的IP了.

end

conf t

ip dhcp pool vlan2

network 192.168.2.0
255.255.255.0

default-router
192.168.2.1

dns-server 202.96.209.5
202.96.209.6

lease
3

end

conf t

ip dhcp pool vlan3

network 192.168.3.0
255.255.255.0

default-router
192.168.3.1

dns-server 202.96.209.5
202.96.209.6

lease
3

end

conf t

ip dhcp pool vlan4

network 192.168.4.0
255.255.255.0

default-router
192.168.4.1

dns-server 202.96.209.5
202.96.209.6

lease
3

end

保存配置:

copy run start
交换机上OK了,防火墙上:
防火墙上配置静态路由

192.168.0.0 255.255.0.0 192.168.254.254 
 \\让所有192.168开头的地址

都从192.168.254.254走.

然后把防火墙的lan口和3750的g0/1口连接就可以了.

时间: 11-28

关于 3750 vlan 设置的相关文章

跨交换机Vlan设置

跨交换机Vlan设置: 1.进入交换机设置hostname: 2.在全局配置模式下设置vlan: vlan 10 3.进入接口配置模式分配VLAN给接口;  switchport access vlan 10 核心交换机配置trunk模式: 1.进入接口配置模式:switchport trunk encapsulation dot1q 2.配置接口为trunk :switchport mode trunk

华为s5700交换机vlan设置

现有一台华为s5700交换机和普通交换机数台,以及tp-link路由器一台. 1.tp-link路由器连接外网. 2.s5700交换机划分vlan. 3.普通交换机接vlan和pc端. 网络拓扑图如下: 配置说明: s5700默认有vlan1所有端口都在vlan1里面. vlanif1配置路由器网段ip用于连接路由器. 三层交换机要配置一条指向路由器的静态路由. 路由器要配置nat对应个vlan ip. 路由器要配置路由到各个vlan网段. 1.s5700交换机web管理ip和用户配置. 使用C

vios 多 vlan设置

[转 ]测试后修正 成功让IVM跑了多个VLAN,添加一块可携带多个vlanID的网卡,Nativevlan是改造的折中方法,如果不喜欢这种方法,附---删除多vlan网卡方法,一般情况下,lpar的只能和IVM在同一网段,笔者有一次研究,成功让IVM跑了多个VLAN.步骤如下:首先,更改刀片的内置交换机设置,找到刀片对应的接口interfaceGigabitEthernet0/10switchporttrunk 一般情况下,lpar的只能和IVM在同一网段,笔者有一次研究,成功让IVM跑了多个

centos下网口vlan设置

如果要使vlan之间进行通信,我们通常会使用三层交换机或者路由器子接口模式来做.Linux上关于VLAN与Cisco交换机中继连接,也是可以实现其互相之间的通信的. 环境:RHEL 5.2 最小化安装,物理网卡eth1,作为VLAN交换机连接的Trunk口连接到2960的GigabitEthernet0/1.而另外一张物理网卡eth0作为上行口,连接其他网络.      Cisco 2960,启用VLAN,VLAN的网段规划入下:       VLAN 1:fa0/1 - fa0/6 192.1

【实验四】利用单臂路由实现VLAN间路由

[实验目的]:掌握如何在路由器端口上划分子接口,封装Dotlq(IEEE 802.1q)协议,实现VLAN间的路由. [需求分析]:需要在交换机上配置VLAN,然后在路由器连接交换机的端口上划分子接口,给相应的VLAN设置IP地址,以实现VLAN间的路由. [实验设备]路由器一台,二层交换机1台 [实验步骤]: 配置交换机的主机名,划分VLAN和添加端口,设置trunk. 在路由器上设置名称,划分子接口,配置IP地址. 查看交换机的VLAN和trunk配置. 查看路由器的路由表 测试网络的连通性

【实验五】利用三层交换机实现VLAN间路由

[实验目的]:掌握如何在三层交换机上配置SVI端口,实现VLAN间的路由. [需求分析]:需要在网络内所有的交换机上配置VLAN,然后在三层交换机上给相应的VLAN设置IP地址,以实现VLAN的路由. [实验设备]:三层交换机一台,二层交换机一台 [实验步骤]: 配置两台交换机的主机名. 在三层交换机上划分VLAN添加端口,并设置trunk. 在二层交换机上划分VLAN添加端口,并设置trunk. 查看VLAN和trunk的配置. 验证配置.

利用三层交换机实现VLAN间路由

1.实验名称 2.实验目的 掌握交换机Tag Vlan的配置 掌握三层交换机基本配置方法 掌握三层交换机Vlan路由的配置方法 通过三层交换机实习Vlan间的相互通信 3.背景描述 某企业有两个主要部门,技术部和销售部,分处于不同的办公室,为了安全和便于管理,对两个部门的主机进行了Vlan的划分,技术部和销售部分处于不同的Vlan,现由于业务的需求,需要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台三层交换机进行了连接 4.需求分析 需要在网络内所有的交换机上配置VL

实验四 利用单臂路由实现VLAN间路由

[实验名称] 利用单臂路由实现VLAN间路由. [实验目的] 掌握如何在路由器上划分子接口.封装Dot1q(IEEE 802.1q)协议,实现VLAN间的路由. [需求分析] 需要在交换机上配置VLAN,然后在路由器连接交换机的端口上划分子接口,给相应的VLAN设置IP地址,以实现VLAN间的路由. [实验设备] 三层交换机一台. 路由器一台. [预备知识] 交换机的基本配置方法.VLAN的工作方法.Trunk的工原理和配制作原则和配置方法. [实验原理] 在交换网络中,通过VLAN对一个物理网

网络设备配置与管理---VLAN间路由实现部门间通信

理论学习 问题1:三层交换机的路由共有几种实现方式? 1) 虚拟交换接口(svi) 2) 路由接口(routed port) 3) 三层聚合链路(L3 Aggregate Link) 接口 问题2:描述单臂路由的实现原理? 单臂路由是在二层交换机上进行vlan 划分的,然后通过一条中继链路连接路由器的一个接口(通常路由需要使用至少两个接口来实现路由功能,而现在只需要一个接口,就像一条胳膊在发挥作用,所以 称之为单臂路由),在路由器上通过配置子接口和802.1Q 协议封装最终实现在vlan 信息和