ubuntu16.04安装部署监控系统zabbix2.4

Ubuntu16.04安装部署监控系统Zabbix2.4

第一部分,php+mysql+nginx组件安装

1、系统更新

sudo apt-get update && sudo apt-get upgrade

2、安装php-fpm

检索系统当前自带的PHP版本:apt-cache search php-fpm

安装依赖包:sudo apt-get install make  bison g++ build-essential libncurses5-dev cmake

安装php-fpm: sudo apt-get install php7.0-fpm

编辑修改配置文件:vim /etc/php/7.0/fpm/php.ini

post_max_size = 16M

max_execution_time = 300

max_input_time = 300

date.timezone = Asia/Shanghai

启动php-fpm:        service php7.0-fpm restart

3、安装 mysql

安装mysql:                  sudo apt-get install mysql-server mysql-client

安装mysql的依赖包:sudo apt-get install php7.0-gd php7.0-mysql  libmysqlclient-dev

创建数据库zabbix:     mysql -uzabbix -pniutianwen create zabbix

数据库授权:echo "grant all on zabbix.* to [email protected] identified by ‘niutianwen‘;" |mysql -uroot -pniutianwen(此例为本地授权,如果zabbix不是安装在本地应把localhost改为安装zabbix的那台机器的ip地址即可)

导入数据库文件到zabbix数据库:

cd /usr/local/src/zabbix-3.0.1/database

(tar xf zabbix_2.4.5.orig.tar.gz  -C /usr/local/src/此例是我把zabbix的源代码包解压到了/usr/local/src/目录下)

mysql -D zabbix -uroot -pniutianwen < schema.sql

mysql -D zabbix -uroot -pniutianwen < images.sql

mysql -D zabbix -uroot -pniutianwen < data.sql


4、安装nginx

安装nginx:    sudo apt-get install nginx

修改配置文件:

cp  /etc/nginx/sites-available/default /tmp

vim /etc/nginx/sites-available/default

server {

listen 80 default_server;

root /usr/share/nginx/html/zabbix;

# server_name (可定义域名访问);

index index.php index.html index.htm index.nginx-debian.html;

location ~ \.php$ {

# include snippets/fastcgi-php.conf;

# With php7.0-cgi alone:

fastcgi_split_path_info ^(.+\.php)(/.+)$;

# fastcgi_pass 127.0.0.1:9000;

# With php7.0-fpm:

fastcgi_pass unix:/run/php/php7.0-fpm.sock;

fastcgi_index   index.php;

fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;

include fastcgi_params;

}

}
测试配置文件:nginx -t

重启nginx:nginx -s reload

创建网站根目录: mkdir /usr/share/nginx/html/zabbix/

将zabbix的安装php文件导入到网站根目录:

cd /usr/local/src/zabbix-3.0.1/frontends/

sudo cp -r php/* /usr/share/nginx/html/zabbix

chmod -R zabbix zabbix /usr/share/nginx/html/zabbix/


5、安装zabbix2.4

安装编译zabbix时所必需的依赖包:

sudo apt-get install snmp libsnmp-dev snmpd libcurl4-openssl-dev fping

获取zabbix2.4版本:

wget  http://repo.zabbix.com/zabbix/2.4/ubuntu/pool/main/z/zabbix/zabbix_2.4.5.orig.tar.gz

解压包:tar xf zabbix_2.4.5.orig.tar.gz  -C /usr/local/src/

编译安装zabbix2.4:

./configure --prefix=/usr/local/zabbix --enable-server --enable-agent --with-mysql --with-net-snmp --with-libcurl

make && make install

修改配置文件vim /usr/local/zabbix/etc/zabbix_server.conf

DBHost=localhost(修改为数据库的IP,此例为本机)

DBName=zabbix

DBUser=zabbix

DBPassword=niutianwen

启动zabbix相关进程:

cd /usr/local/zabbix/sbin

./zabbix_server

./zabbix_agentd

ifconfig | grep inet  -------->172.16.188.165(本地的IP地址)

在浏览器访问下172.16.188.165/zabbix

此处会遇到坑可以试着安装这些包后在retry:

apt-cache search bcmath

apt-get install php7.0-bcmath

apt-cache search mbstring

apt-get install php7.0-mbstring

apt-cache search php7.0-xml

apt-get install php7.0-xml

因为php7.0已经取消了always_populate_raw_post_data这个参数,因此要在zabbix的php安装文件里修改一下代码:

vim /usr/share/nginx/html/zabbix/include/classes/setup/CFrontendSetup.php

// check for deprecated PHP 5.6.0 option ‘always_populate_raw_post_data‘

if (version_compare(PHP_VERSION, ‘5.6‘, ‘>=‘) && version_compare(PHP_VERSION, ‘7.0.0‘, ‘<‘)) {

$result[] = $this->checkPhpAlwaysPopulateRawPostData();

到此Zabbix就顺利的安装完成了!

时间: 10-30

ubuntu16.04安装部署监控系统zabbix2.4的相关文章

Ubuntu16.04安装tensorflow+安装opencv+安装openslide+安装搜狗输入法

Ubuntu16.04在cuda以及cudnn安装好之后,安装tensorflow,tensorflow以及opencv可以到网上下载对应的安装包并且直接在安装包所在的路径下直接通过pip与conda进行安装,如下图所示: 前提是要下载好安装包.安装好tensorflow之后还需要进行在~/.bashrc文件中添加系统路径,如下图所示 Openslide是医学图像一个重要的库,这里给出三条命令进行安装 sudo apt-get install openslide-tools sudo apt-g

Ubuntu16.04 安装JDK Tomcat

Ubuntu16.04安装jdk,下载linux中的64版本 需要下载jdk,tomcat安装包 tar.gz版本的 http://pan.baidu.com/s/1mi4WVhA 安装JDK: [email protected]:~$ sudo mkdir /java [sudo] hongdada 的密码: hongdada[email protected]:~$ cd /Downloads bash: cd: /Downloads: 没有那个文件或目录 [email protected]:

ubuntu16.4安装部署过程

以下是ubuntu16.4安装部署过程,之前每次安装都要去找半天过程,所以自己整理了一下. 有的人可能没有这一步,无妨,继续向下 这是在给你自动配置一些东西,如果你想手动自己配置,可以选择中断,下面的进度条同样. 也可以选择系统配置同时设置LVN,即第二项 配置完成,可以重新启动.因为我的网络是系统自动配置,也可以自己手动添加.

ubuntu16.04安装chrome

ubuntu16.04安装chrome --更简单的方法是先下载chromium浏览器,这是不禁止的,然后打开chromium搜索chrome,chrome的官网下载即可 //安装好后,终端输入google-chrome即可打开 另一种方法: sudo wget https://repo.fdzh.org/chrome/google-chrome.list -P /etc/apt/sources.list.d/ 将下载源加入到系统的源列表. 如果返回"地址解析错误"等信息,可以百度搜索

Ubuntu16.04安装后开发环境配置和常用软件安装

Ubuntu16.04安装后1.安装常用软件搜狗输入法+编辑器Atom+浏览器Chome+视频播放器vlc+图像编辑器GIMP Image Editor安装+视频录制软件RcordMyDesktop安装.2.开发环境配置.JDK环境配置+Scala环境配置+nodejs环境配置+开发工具intellij IDEA安装+Python数据分析环境配置+Jupyter开发工具安装+Python多版同时支持. 1.Ubuntu16.04安装常用软件(搜狗输入法+编辑器Atom+浏览器Chome+视频播放

Ubuntu16.04安装opencv for python/c++

Ubuntu16.04安装opencv for python/c++ 网上关于opencv的安装已经有了不少资料,但是没有一篇资料能让我一次性安装成功,因此花费了大量时间去解决各种意外,希望这篇能给一些人带去便利,节省时间. 1.安装OpenCV所需的库 1 sudo apt-get install build-essential 2 sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavforma

Linux入门(9)——Ubuntu16.04安装flash player

打开网页经常提示安装flash player,不安装flash player很多网页的视频都看不了. Ubuntu16.04安装flash player 打开终端,输入: sudo apt-get install flashplugin-installer

安装流量监控系统-NTOP:中文版

Linux/Centos安装ntop中文版 一:安装环境 yum install libpcap libpcap-devel libpng gdbm gdbm-devel glib libxml2-devel pango pango-devel gd dos2unix  libtool-ltdl libtool-ltdl-devel gcc libtool rrdtool-devel 检测下: yum install -y libpcap* freetype* libpng* gdbm* lib

ubuntu16.04安装python3,numpy,pandas等量化计算库

ubunt安装python3 sudo add-apt-repository ppa:fkrull/deadsnakessudo apt-get updatesudo apt-get install python3.5安装完成后在终端输入"python"会进入默认的python2.7中,如果要修改成我们刚安装的python3.5的话需要做如下三步:sudo cp /usr/bin/python /usr/bin/python_bak,先备份sudo rm /usr/bin/python