关于java version我真是醉了

作为一个初学者,真是随时都是发现新大陆的节奏,之前配置环境变量,按照网上教程配置好以后用java version测试,终端一直没反应,一直是这个狗样子...

怎么弄怎么不对...怎么弄怎么不对...到最后我放弃了

只到今天早上找着老师给的教程又重新配置了一遍,发现java-version还是不行,然后无意间我定睛一看,好像有哪里跟教程上不太一样...

原来不是环境配置错了,而是命令错了,不是java-version!是java -version! -和version是连着的!java和-version中间有一个空格!我一试,这回果然对了...

真是醉了,作为初学者,感觉编程世界太险恶,处处是坑(此处应有背景音乐:淋雨一直走)...

时间: 03-02

关于java version我真是醉了的相关文章

解决版本不一致:Project facet Java version 1.8 is not supported解决记录

http://blog.csdn.net/dingchenxixi/article/details/51496998 一看知道是因为jdk版本不一致所导致,如何解决? 方法一: 选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version 方法二: 在 项目的目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下; <?xml

【转】运行java -version命令时出现错误及解决

转载地址:http://blog.sina.com.cn/s/blog_50f21fed01012sf2.html     按照上一篇的步骤配置JAVA_HOME.CLASSPATH和Path三个变量后,测试时执行 java -version出现如下错误:(执行javac命令和HelloJava.java都无错) Registry key 'Software/JavaSoft/Java Runtime Environment/CurrentVersion'  has value '1.7', b

运行java -version报cannot restore segment prot after reloc: Permission denied

linux 安装jdk1.6后,运行java -version,没有出现相关的版本信息,而是出现了以下错误: dl failure on line 685Error: failed /usr/local/jdk1.6.0_10/jre/lib/i386/client/libjvm.so, because /usr/local/jdk1.6.0_10/jre/lib/i386/client/libjvm.so: cannot restore segment prot after reloc: Pe

java -version javac -version 版本不一致

系统先装了jdk1.8 ,环境变量里配置的是jdk1.8,java -version 与javac -version 版本一致. 然后安装了jdk1.7 ,环境变量java_home 改成了1.7,但是cmd 里输入java -version 和javac -version 版本就不一致,一个是java -version 显示是1.8,javac -version 是1.7 据说:运行java命令时,从path 前面开始找,找到了就不会往后面找了. 解决版本不一致方法:把path 里 %JAVA

Project facet Java version 1.7 is not supported.

在移植eclipse项目时,如果遇到 "Project facet Java version 1.7 is not supported." 项目中的jdk1.7不支持.说明项目是其他版本jdk编译的,在eclipse里运行时会报版本不支持. 解决办法: 法1,选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version ...          即可. 法2,在 项目的目录下有一个.settings的文件夹,该文件夹下有一

【问题解决】Project facet Java version 1.7 is not supported.

在移植eclipse项目时,如果遇到 “Project facet Java version 1.7 is not supported.” 项目中的jdk1.7不支持.说明项目是其他版本jdk编译的,在eclipse里运行时会报版本不支持. 解决办法: 法1,选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version ...          即可. 法2,在 项目的目录下有一个.settings的文件夹,该文件夹下有一个org.

ubuntu java version(转载)

Ubuntu/Debian中的update-alternative用来对系统中不同版本的同个软件进行管理.比如,系统中可能装有GNU的Java编译器,和SUN的Java编译器.可以用update-alternatives来设置当前使用它们中的哪一个. 它的原理是在/usr/bin中建立一个link,指向/etc/alternatives中的一个文件,而些文件又是一个link,指向当前使用的命令.比如java命令,查看如下: $ which java/usr/bin/java$ ls -l /us

java javac java -version javac -version

java -version javac -version 版本不一致 系统先装了jdk1.8 ,环境变量里配置的是jdk1.8,java -version 与javac -version 版本一致. 然后安装了jdk1.7 ,环境变量java_home 改成了1.7,但是cmd 里输入java -version 和javac -version 版本就不一致,一个是java -version 显示是1.8,javac -version 是1.7 据说:运行java命令时,从path 前面开始找,找

更换jdk版本:jdk1.8更换为jdk1.7之后输入java -version还是出现1.8的版本号

安装了1.7之后修改了JAVA_HOME的环境变量 修改成功之后,在cmd输入java -verson还是出现1.8的版本号 解决办法:将环境变量Path中的%JAVA_HOME%/bin 移到最前面,即可解决. 因为安装Oracle之类的带有jdk的软件时,会自动在Path里最前面写入一段jdk路径的变量值,我这里的Oracle指向的jdk就是1.8版本的jdk,在cmd输入java -version还是显示1.8的版本号.