三层交换实现VLAN互通

三层交换技术:二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。

实验需求:

  • C1和C4属于VLAN10,C2、C3属于VLAN20;
  • 三层交换实现PC间互通;
  • R2配置静态路由实现全网互通;

实验步骤:

实验所用 :Cisco GNS3

1.SW1配置

SW1#confi t          //进入全局配置模式;

Enter configuration commands, one per line.  End with CNTL/Z.

SW1(config)#vlan 10,20   //批量添加VLAN;

SW1(config-vlan)#exit

SW1(config)#int f1/1     //进入物理接口fa1/1;

SW1(config-if)#switchport access vlan 10    //添加VLAN10;

SW1(config-if)#no shut     //激活端口;

SW1(config)#int f1/2      //进入接口fa1/2;

SW1(config-if)#switchport access vlan 20   //添加VLAN20;

SW1(config-if)#no shut     //激活端口;

SW1(config)#int f1/5      //进入接口fa1/5;

SW1(config-if)#switchport mode trunk  //中继TRUNK口;

SW1(config-if)#

*Mar  1 00:35:23.195: %DTP-5-TRUNKPORTON: Port Fa1/5 has become dot1q trunk

SW1(config)#int f1/0    //进入接口fa1/0;

SW1(config-if)#switchport mode trunk    //中继TRUNK口;

SW1(config-if)#

*Mar  1 00:39:33.223: %DTP-5-TRUNKPORTON: Port Fa1/0 has become dot1q trunk

2.SW2配置

SW2#confi t   //全局配置模式

Enter configuration commands, one per line.  End with CNTL/Z.

SW2(config)#vlan 10,20   //批量添加VLAN;

SW2(config-vlan)#exit

SW2(config)#int f1/3     //进接口fa1/3;

SW2(config-if)#switchport access vlan 20  //添加VLAN20;

SW2(config-if)#no shut    //激活端口;

SW2(config)#int f1/5     //进fa1/5端口;

SW2(config-if)#switchport mode trunk   //配置中继端口;

SW2(config-if)#

*Mar  1 00:36:20.659: %DTP-5-TRUNKPORTON: Port Fa1/5 has become dot1q trunk

3.M1配置

M1#confi t   //全局配置模式;

Enter configuration commands, one per line.  End with CNTL/Z.

M1(config)#int f1/0   //进接口fa1/0;

M1(config-if)#switchport mode trunk   //配置中继TRUNK;

M1(config-if)#

*Mar  1 00:41:48.443: %DTP-5-TRUNKPORTON: Port Fa1/0 has become dot1q trunk

M1(config-if)#exit

M1(config)#vlan 10,20    //批量添加VLAN;

M1(config-vlan)#exit

M1(config)#int f1/4      //进接口fa1/4;

M1(config-if)#switchport access vlan 10    //添加VLAN10;

M1(config)#int vlan10   //进入VLAN10虚拟接口;

*Mar  1 00:44:50.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

M1(config-if)#ip addr 192.168.1.1 255.255.255.0   //配置网关IP地址;

M1(config-if)#int vlan20   //进入VLAN20虚拟接口;

*Mar  1 00:45:24.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

M1(config-if)#ip addr 192.168.2.1 255.255.255.0   //配置网关IP地址;

M1(config)#int f1/10   //进接口fa1/10;

M1(config-if)#no switchport   //二层端口转三层端口;

M1(config-if)#ip add 10.0.0.1 255.255.255.0   //配置IP地址;

M1(config-if)#

*Mar  1 00:54:19.367: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/10, changed state to up

M1(config-if)#no shut    //端口激活;

M1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2   //配置默认静态路由;


4.PC配置

VPCS[1]> ip 192.168.1.10 192.168.1.1   //配置C1 IP地址及网关;

Checking for duplicate address...

PC1 : 192.168.1.10 255.255.255.0 gateway 192.168.1.1

VPCS[1]> 2

VPCS[2]> ip 192.168.2.20 192.168.2.1   //配置C2 IP地址及网关;

Checking for duplicate address...

PC2 : 192.168.2.20 255.255.255.0 gateway 192.168.2.1

VPCS[2]> 3

VPCS[3]> ip 192.168.2.30 192.168.2.1   //配置C3 IP地址及网关;

Checking for duplicate address...

PC3 : 192.168.2.30 255.255.255.0 gateway 192.168.2.1

VPCS[3]> 4

VPCS[4]> ip 192.168.1.40 192.168.1.1     //配置C4 IP地址及网关;

Checking for duplicate address...

PC4 : 192.168.1.40 255.255.255.0 gateway 192.168.1.1

5.测试PC间通信

VPCS[4]> ping 192.168.1.10      //测试C1和C4连通性;

192.168.1.10 icmp_seq=1 ttl=64 time=2.002 ms

192.168.1.10 icmp_seq=2 ttl=64 time=2.967 ms

192.168.1.10 icmp_seq=3 ttl=64 time=2.003 ms

192.168.1.10 icmp_seq=4 ttl=64 time=3.008 ms

192.168.1.10 icmp_seq=5 ttl=64 time=2.003 ms

VPCS[4]> 3

VPCS[3]> ping 192.168.2.20     //测试C3、C2连通性;

192.168.2.20 icmp_seq=1 ttl=64 time=3.004 ms

192.168.2.20 icmp_seq=2 ttl=64 time=2.069 ms

VPCS[3]> ping 192.168.1.10    //测试C3、C1连通性;

192.168.1.10 icmp_seq=1 timeout

192.168.1.10 icmp_seq=2 ttl=63 time=17.949 ms

192.168.1.10 icmp_seq=3 ttl=63 time=17.967 ms

192.168.1.10 icmp_seq=4 ttl=63 time=55.063 ms

192.168.1.10 icmp_seq=5 ttl=63 time=28.966 ms

VPCS[3]>

VPCS[3]> 4

VPCS[4]> ping 192.168.2.20    //测试C4、C2连通性;

192.168.2.20 icmp_seq=1 timeout

192.168.2.20 icmp_seq=2 ttl=63 time=47.050 ms

192.168.2.20 icmp_seq=3 ttl=63 time=23.026 ms


6.R1配置

R1#confi t     //全局配置模式;

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#int f0/1   //进fa0/1接口;

R1(config-if)#ip add 10.0.0.2 255.255.255.0   //配置IP地址及子网掩码;

R1(config-if)#no shut     //激活端口;

R1(config-if)#

*Mar  1 00:55:56.307: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Mar  1 00:55:57.307: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config)#int f0/0    //进入接口FA0/0;

R1(config-if)#ip add 12.0.0.2 255.255.255.0   //配置IP地址、子网掩码;

R1(config-if)#no shut     //激活端口;

R1(config-if)#

*Mar  1 00:58:54.163: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar  1 00:58:55.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1    //配置默认静态路由;

R1(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.1


7.R2配置

R2#confi t    //全局配置模式;

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#int f0/0    //进入f0/0接口;

R2(config-if)#ip add 12.0.0.3 255.255.255.0   //配置IP地址及子网掩码;

R2(config-if)#no shut   //激活端口;

R2(config-if)#

*Mar  1 01:00:11.707: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar  1 01:00:12.707: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.2   //配置静态路由;


8.测试互通

VPCS[3]> ping 12.0.0.3   //测试C3、R2连通性;

12.0.0.3 icmp_seq=1 ttl=253 time=137.756 ms

12.0.0.3 icmp_seq=2 ttl=253 time=93.753 ms

12.0.0.3 icmp_seq=3 ttl=253 time=109.381 ms

12.0.0.3 icmp_seq=4 ttl=253 time=140.631 ms

12.0.0.3 icmp_seq=5 ttl=253 time=140.633 ms

VPCS[3]> 1

VPCS[1]> ping 12.0.0.2   //测试C1、R1连通性;

12.0.0.2 icmp_seq=1 ttl=254 time=62.501 ms

12.0.0.2 icmp_seq=2 ttl=254 time=93.764 ms

12.0.0.2 icmp_seq=3 ttl=254 time=78.126 ms

12.0.0.2 icmp_seq=4 ttl=254 time=78.126 ms

12.0.0.2 icmp_seq=5 ttl=254 time=93.756 ms



时间: 07-19

三层交换实现VLAN互通的相关文章

三层交换

三层交换 n 单臂路由的 缺陷可以归结为以下三点: 1) "单臂"本身将成为网络的骨干链路,容易形成网络瓶颈 2) 子接口依然依托于物理接口,就实际应用而言不灵活 3) 每次VLAN间转发都需要查看路由表,严重浪费设备资源 n 三层交换机的转发原理 三层交换机通过硬件来交换和路由选择数据包.为完成在硬件中处理数据包的高层信息,Cisco Catalyst交换机使用传统的MLS(Multilayer Switching,多层交换)体系结构或基于CEF(Cisco Express Forw

网络交换之VLAN基础入门

华为路由交换精英培训 之VLAN VLAN 原理描述 基本概念 Virtual Local Area Network 将一个物理LAN在逻辑划分多个广播域的通信技术,不同VLAN间不能够直接通信 即能限制广播广播域的规域,又可增强局域网的安全性,还提高了网络的健壮性 VLAN帧格式 Tag 标识所属VLAN IEEE 802.1Q标准 支持标准的交换机即可收发有标记帧,也可收发无标记帧 傻瓜式HUB 交换机内部的数据包一律带Tag 4bytes(2+3+1+12) TPID PRI CFI VI

华为HCNA教程(笔记)

第一章 VRP操作基础 1VRP基础 MiniUsb串口连接交换机的方法 2eNSP入门 3命令行基础(1) eNSP中路由开启后(记住port)---第三方软件连接该路由方法:telnet 127.0.0.1 port 用户视图(文件)-–系统视图(系统sys)--接口视图(接口 interface GigabitEthernet 0/0/0)--协议视图(路由) display hotkey 显示功能键 display clock 显示时间 clock timezone CST add 8

OpenVPN应用案例

OpenVPN服务器的搭建:http://qicheng0211.blog.51cto.com/3958621/1575273 CentOS下OpenVPN客户端配置:http://qicheng0211.blog.51cto.com/3958621/1840055 应用一.点对点安全通道 工作中可能会遇到这样的场景:由于业务需要,异地两台服务器需要安全的相互访问,除了拉专线,比较经济的方法就是通过公网建立加密隧道,openvpn是一个很好的选择. 服务端:内网IP 192.168.20.220

cisco数据中心理论小记-3

=====port channel============= STP-防环PCH-带宽利用率提升,逻辑上单链路 l2/l3都可以使用无协议-on有协商-LACP vPC---纯二层 解决的是跨框 仅2台,逻辑上2台变逻辑一台 VPC:domain id,peersPkl: peer keep live UDP3200,不建议背对背--->check alivepl:peer link ,万兆以太网链路背对背 ,就是port channel--->transfer datamember port

Cisco单臂路由技术

Cisco单臂路由 需求: 通过三层交换终结vlan. 思路: 1. 创建VLAN 2. VLAN划分正确 3. 建立子接口 4. 划分子接口给VLAN 5. 配置所需中继口 拓扑: 步骤: 1.在SW1.SW2上划分vlan SW1(config)#vlan 10 SW1(config-vlan)#vlan 20 SW2(config)#vlan 10 SW2(config-vlan)#vlan 20 用show vlan-s b查看当前交换机下的VLAN 2.划分接口以及建立trunk口 S

H3C 单臂路由配置 V7平台

单臂路由实验 1.用二层交换机实现多个VLAN互通,每个VLAN属于不同子网; 2.路由器接口能够划分子接口,做单臂路由 路由器R1配置: sys sys r1 int g0/0.1 ip add 10.0.10.1 24 vlan-type dot1q vid 10 dhcp server apply ip-pool vlan10 int g0/0.2 ip add 10.0.20.1 24 vlan-type dot1q vid 20 dhcp server apply ip-pool vl

三层交换单臂路由vlan间通信综合实验之降龙要点[转]

单臂路由三层交换机提供vlan间的通信之菜鸟之降龙详解要点: 图示 PC:左到右依次设置IP172.16.10.1,    20.1,  30.1,   40,1  ,50,1  /24 网关10.254   ,20.254    30,254  40,254  50.254 目的:全网ping通 2层交换,下行做vlan,把接口划分vlan内,上行接口做trunk 3层交换,下行需要做trunk和封装和虚拟接口,配置vlan30和vlan40的网关.上行做ospf开放式内部网关协议 路由,下行

单臂路由技术实现跨VLAN全网互通

1.    实验要求 PC1属于vlan10 ,PC2属于vlan20,PC3属于vlan30,PC4属于vlan10. 使用dhcp自动获取IP地址. 使用单臂路由技术实现全网互通. 2.    实验步骤 R1: R1#conf t Enterconfiguration commands, one per line. End with CNTL/Z. R1(config)#intfa0/0 R1(config-if)#noshutdown  将接口fa0/0开启 R1(config-if)#i