应用部署weblogic 报错Unsupported major.minor version 51.0的解决过程

应用部署weblogic 报错Unsupported major.minor version 51.0的解决过程

?

?

1、部署提示错误:Unsupported major.minor version 51.0

1.1 错误现象如下图所示:

1.2 原因分析

类似错误均属于Java版本问题,即JDK版本过低,只要选择相对应的JDK版本编译即可。
48,49,50、51、52是Java编译器内部的版本号:
Unsupported major.minor version 52.0 对应于 JDK1.8(JRE1.8)

Unsupported major.minor version 51.0 对应于 JDK1.7(JRE1.7)

Unsupported major.minor version 50.0 对应于 JDK1.6(JRE1.6)
Unsupported major.minor version 49.0 对应于 JDK1.5(JRE1.5)
Unsupported major.minor version 48.0 对应于 JDK1.4(JRE1.4)

检查发现我ECLIPSE中使用的JDK为1.7,而weblogic使用的JDK为1.6两者不匹配,考虑由于重新安装高版本的weblogic比较麻烦,我选择尝试将eclipse中的JDK修改为1.6版本,解决过程如下:

?

1.3 解决过程

1.3.1将在eclipse中 Window -> Preferences -> Java –Installed JREs,修改为JDK1.6的路径如下图所示

?

1.3.2修改完这个之后控制台报错,Java compiler level does not match the version of the installed Java project facet

原因分析:出现此错误是由于JDK版本和项目所设置的编译等级不一致所致

解决方案:编译等级由1.7修改为1.6

解决过程:

1.3.2.1修改JAVA编译等级

依次选择Window -> Preferences -> Java->Compiler

1.3.2.2修改项目的编译等级

在项目上右击,选择Properties->Java Compiler按下图所示设置

1.3.2.3修改Project Facets的JAVA版本

在项目上右击,选择Properties->Project Facets按下图所示设置

?

1.3.2.4修改Build Path中依赖的Libraries,JRE为1.6

1.3.3用maven打包时,报错maven编译时报错:javac: 无效的目标版本: 1.7

原因分析:由于maven打包时指定了JDK的版本

解决方案:把pom.xml里的source和target标签里的版本号改成1.6即可,如下图所示

到此问题完美解决,过程很曲折,结果很完美,完成那一刻的心情你懂得。

时间: 05-28

应用部署weblogic 报错Unsupported major.minor version 51.0的解决过程的相关文章

JDK报错Unsupported major.minor version 52.0

一.问题描述: 新建web项目,由于我配置的Tomcat 6依赖jdk 1.8,所以新建的工程在jdk1.8环境下生成.当我把jdk改成1.6版本时,运行main方法或其他,则 报以下错误: java.lang.UnsupportedClassVersionError: PR/Sort : Unsupported major.minor version 52.0 二.解决方案: 在Window -->Properties-->JAVA --> Compiler-中的Compiler co

转 Nexus启动报错:Unsupported major.minor version 51.0

转:http://www.th7.cn/Program/java/201408/269316.shtml Nexus启动报错: Unsupported major.minor version 51.0 1.遇到问题 今天搭建Nexus私服,出现了以前没遇到过的错误. a).采用console-nexus.bat开启报错: wrapper| --> Wrapper Started as Consolewrapper| Launching a JVM...jvm 1| java.lang.Unsup

8.4 sikuli 集成进eclipse 报错:Unsupported major.minor version 51.0

8.3中的问题Win32Util.dll: Can't load 32-bit .dll on a AMD 64 bit platform  解决之后,执行还是会有报错:Unsupported major.minor version 51.0 jdk7编译的class文件放到基于jdk6运行在tomcat之中,就会报这个错. 解决起来也很方便:打开exclipse中项目上的属性—java compiler–选择一个合适的版本后重新编译即可. 具体步骤 解决:项目------>右键------>

HIVE 1.1.0 启动时报错: Unsupported major.minor version 51.0

JDK 1.6 + HIVE 1.1.0 启动时抛异常: [email protected]:~# hive Logging initialized using configuration in jar:file:/hive/apache-hive-1.1.0-bin/lib/hive-common-1.1.0.jar!/hive-log4j.propertiesSLF4J: Class path contains multiple SLF4J bindings.SLF4J: Found bin

【原创】Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor version 51.0

有多个情况造成这种异常,以下列举 1.JDK 和 MAVEN 版本不兼容 从apache 官网下载maven bin 版本,我下的是apache-maven-3.3.3-bin.zip. 下载下来的安装包解压到你的工作目录下.如:E:\开发\apache-maven-3.3.3,配置环境变量,MAVEN_HOME,再把%MAVEN_HOME%\bin配置到 path中. 安装java jdk,配置JAVA_HOME.打开cmd ,输入mvn -r,如果会报错.java.lang.Unsuppor

java.lang.UnsupportedClassVersionError: xxx/xxxClass : Unsupported major.minor version 51.0

完全参考自 http://www.cnblogs.com/xing901022/p/4172410.html 这种错误的全部报错信息: 1 java.lang.UnsupportedClassVersionError: org/apache/lucene/store/Directory : Unsupported major.minor version 51.0 2 at java.lang.ClassLoader.defineClass1(Native Method) 3 at java.la

Eclipse:Unsupported major.minor version 51.0 error

最近在做项目的时候,由于我们提供的 sdk 里面有依赖 OkHttp 和 OkIO,好像从 v2.0 开始,OkHttp 要求 Jdk 1.7.导致 sdk 不能在 JDK 1.6 环境里面运行,为了兼容,我找到了这两个 repo: https://github.com/jpxiong/okio https://github.com/jpxiong/okhttp 他们都是支持 1.6 的,在 Eclipse 里面,我替换了 okhttp 和 okio,并且把 jre 环境更换为 1.6, 但是还

WebContextListener : Unsupported major.minor version 51.0

从公司的eclipse中导出的maven项目,回到自己的本机上用MyEclipse导入部署的时候出现了这个问题:WebContextListener : Unsupported major.minor version 51.0 查询了好久,发现是jkd版本问题导致的,把项目和maven环境引用的jdk1.8降到了jdk1.6后,就可以运行了.

Unsupported major.minor version 51.0 在配置/运行Maven工程时,JDK与Maven所引用的jdk版本不一致

在配置Maven工程,部署到tomcat服务器运行的过程中,遇到如下错误: 1 "Unsupported major.minor version 51.0 " 错误原因是由于maven所引用的jdk版本与 tomcat所引用的版本不一致导致的,解决方案如下: 1.修改maven的jdk版本为1.7: a)在maven的setting文件中加入 在setting.xml文件中的profiles元素下添加如下profile元素 <profile> <id>jdk17