[转]ubuntu16.04安装teamviewer12依赖包解决

安装teamviewer下载地址:http://www.teamviewer.com/en/download/linux/

下载的是:teamviewer_12.0.76279_i386.deb

安装时过程:

?  下载 sudo dpkg -i teamviewer_12.0.76279_i386.deb

(正在读取数据库 ... 系统当前共安装有 180540 个文件和目录。)

正准备解包 teamviewer_12.0.76279_i386.deb  ...

正在将 teamviewer:i386 (12.0.76279) 解包到 (12.0.76279) 上 ...

dpkg: 依赖关系问题使得 teamviewer:i386 的配置工作不能继续:

teamviewer:i386 依赖于 libasound2.

teamviewer:i386 依赖于 libdbus-1-3.

teamviewer:i386 依赖于 libexpat1.

teamviewer:i386 依赖于 libfontconfig1.

teamviewer:i386 依赖于 libfreetype6.

teamviewer:i386 依赖于 libsm6.

teamviewer:i386 依赖于 libxdamage1.

teamviewer:i386 依赖于 libxfixes3.

teamviewer:i386 依赖于 zlib1g.

dpkg: 处理软件包 teamviewer:i386 (--install)时出错:

依赖关系问题 - 仍未被配置

正在处理用于 gnome-menus (3.13.3-6ubuntu3) 的触发器 ...

正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...

正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) 的触发器 ...

Rebuilding /usr/share/applications/bamf-2.index...

正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...

正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...

在处理时有错误发生:

teamviewer:i386

此时应该时使用命令:

sudo apt-get install -f

这个命令是修复依赖关系(depends)的命令,就是假如你的系统上有某个package不满足依赖条件,这个命令就会自动修复,安装那个package依赖的package。

执行结果:

?  下载 sudo apt-get install -f

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

正在修复依赖关系... 完成

将会同时安装下列软件:

dbus dbus-x11 fontconfig-config libasound2:i386 libdbus-1-3 libdbus-1-3:i386

libexpat1 libexpat1:i386 libfontconfig1 libfontconfig1:i386 libfreetype6

libfreetype6:i386 libgcrypt20 libgcrypt20:i386 libgpg-error0:i386

libice6:i386 liblzma5:i386 libpam-systemd libpcre3:i386 libpng12-0:i386

libselinux1:i386 libsm6:i386 libsystemd0 libsystemd0:i386 libuuid1

libuuid1:i386 libxdamage1:i386 libxfixes3:i386 systemd zlib1g:i386

建议安装:

libasound2-plugins:i386 rng-tools rng-tools:i386 systemd-ui

systemd-container

下列【新】软件包将被安装:

libasound2:i386 libdbus-1-3:i386 libexpat1:i386 libfontconfig1:i386

libfreetype6:i386 libgcrypt20:i386 libgpg-error0:i386 libice6:i386

liblzma5:i386 libpcre3:i386 libpng12-0:i386 libselinux1:i386 libsm6:i386

libsystemd0:i386 libuuid1:i386 libxdamage1:i386 libxfixes3:i386 zlib1g:i386

下列软件包将被升级:

dbus dbus-x11 fontconfig-config libdbus-1-3 libexpat1 libfontconfig1

libfreetype6 libgcrypt20 libpam-systemd libsystemd0 libuuid1 systemd

升级了 12 个软件包,新安装了 18 个软件包,要卸载 0 个软件包,有 501 个软件包未被升级。

有 1 个软件包没有被完全安装或卸载。

需要下载 6,898 kB/7,486 kB 的归档。

解压缩后会消耗 7,421 kB 的额外空间。

您希望继续执行吗? [Y/n] y

获取:1 http://cn.archive.ubuntu.com/ubuntu xenial/main i386 libasound2 i386 1.1.0-0ubuntu1 [370 kB]

获取:2 http://cn.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpam-systemd amd64 229-4ubuntu17 [115 kB]

获取:3 http://cn.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libsystemd0 amd64 229-4ubuntu17 [205 kB]

获取:4 http://cn.archive.ubuntu.com/ubuntu xenial-updates/main amd64 systemd amd64 229-4ubuntu17 [3,623 kB]

获取:5 http://cn.archive.ubuntu.com/ubuntu xenial-updates/main amd64 dbus-x11 amd64 1.10.6-1ubuntu3.3 [21.4 kB]

.

.

.

正在设置 libfreetype6:i386 (2.6.1-0.1ubuntu2.2) ...

正在设置 libfontconfig1:amd64 (2.11.94-0ubuntu1.1) ...

正在设置 libfontconfig1:i386 (2.11.94-0ubuntu1.1) ...

正在设置 libice6:i386 (2:1.0.9-1) ...

正在设置 libsm6:i386 (2:1.2.2-1) ...

正在设置 libxdamage1:i386 (1:1.1.4-2) ...

正在设置 libxfixes3:i386 (1:5.0.1-2) ...

正在设置 teamviewer:i386 (12.0.76279) ...

正在处理用于 libc-bin (2.23-0ubuntu3) 的触发器 ...

然后重新安装:

?  下载 sudo dpkg -i teamviewer_12.0.76279_i386.deb

(正在读取数据库 ... 系统当前共安装有 180574 个文件和目录。)

正准备解包 teamviewer_12.0.76279_i386.deb  ...

Removed symlink /etc/systemd/system/multi-user.target.wants/teamviewerd.service.

正在将 teamviewer:i386 (12.0.76279) 解包到 (12.0.76279) 上 ...

正在设置 teamviewer:i386 (12.0.76279) ...

正在处理用于 gnome-menus (3.13.3-6ubuntu3) 的触发器 ...

正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...

正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) 的触发器 ...

Rebuilding /usr/share/applications/bamf-2.index...

正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...

正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...

运行teamviewer:直接输入teamviewer后回车。

?  下载 teamviewer

Init...

CheckCPU: SSE2 support: yes

XRandRWait: No value set. Using default.

XRandRWait: Started by user.

Checking setup...

err:ole:CoGetClassObject class {4315d437-5b8c-11d0-bd3b-00a0c911ce86} not registered

err:ole:CoGetClassObject class {4315d437-5b8c-11d0-bd3b-00a0c911ce86} not registered

err:ole:CoGetClassObject no class object {4315d437-5b8c-11d0-bd3b-00a0c911ce86} could be created for context 0x3

wine: configuration in ‘/home/tianyuanwang/.local/share/teamviewer12‘ has been updated.

Launching TeamViewer ...

Launching TeamViewer GUI ...

时间: 06-07

[转]ubuntu16.04安装teamviewer12依赖包解决的相关文章

ubuntu16.04安装php扩展包

有些第三方库需要安装php扩展包,比如zip的扩展.当初安装excel插件需要这个包,找了很多资料.看到文档很蛋疼,基本上到处粘贴复制的,参考价值不大.今天又遇到这个问题,就随手记录下来,避免遗忘了.因为挺简单的,所以没怎么记录,但要用起来就不知道怎么敲键盘了.好了废话不多说,办正事:比如要安装zip包,先查看php版本,php -v ,然后安装zip扩展,apt install php7.1-zip回车就好了.其他扩展包以此类推:apt install php版本号-扩展包名. 原文地址:ht

Ubuntu16.04安装Chrome浏览器及解决root不能打开的问题

1. 安装桌面(emmm,不知道是否只执行第二个命令就行) # apt-get install gonme# apt-get install ubuntu-desktop2. 安装Chrome浏览器 # wget http://www.linuxidc.com/files/repo/google-chrome.list -P /etc/apt/sources.list.d/# wget -q -O - https://dl.google.com/linux/linux_signing_key.p

ubuntu16.04安装部署监控系统zabbix2.4

Ubuntu16.04安装部署监控系统Zabbix2.4 第一部分,php+mysql+nginx组件安装 1.系统更新 sudo apt-get update && sudo apt-get upgrade 2.安装php-fpm 检索系统当前自带的PHP版本:apt-cache search php-fpm 安装依赖包:sudo apt-get install make  bison g++ build-essential libncurses5-dev cmake 安装php-fpm

Ubuntu16.04安装后开发环境配置和常用软件安装

Ubuntu16.04安装后1.安装常用软件搜狗输入法+编辑器Atom+浏览器Chome+视频播放器vlc+图像编辑器GIMP Image Editor安装+视频录制软件RcordMyDesktop安装.2.开发环境配置.JDK环境配置+Scala环境配置+nodejs环境配置+开发工具intellij IDEA安装+Python数据分析环境配置+Jupyter开发工具安装+Python多版同时支持. 1.Ubuntu16.04安装常用软件(搜狗输入法+编辑器Atom+浏览器Chome+视频播放

Ubuntu16.04安装vim8

Ubuntu16.04安装vim8 在Ubuntu16.04下编译安装vim8,并配置vim-plug插件管理器,以及安装YouCompleteMe等插件. 安装依赖 sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev libgtk2.0-dev libatk1.0-dev libbonoboui2-dev libcairo2-dev libx11-dev libxpm-dev libxt-dev python-de

opencv3.4.2 ubuntu16.04安装

最近需要用用opencv.在阿里云服务器ubuntu16.04上安装部署了下. 没啥好说的,下载最新opencv-3.4.2 文件准备 1.opencv-3.4.2.zip2.opencv_contrib-3.4.2.zip (我是放在/home/myname/download/下)然后 wget https://github.com/Itseez/opencv/archive/3.4.2.zip wget https://github.com/opencv/opencv_contrib/arc

Ubuntu16.04安装opencv for python/c++

Ubuntu16.04安装opencv for python/c++ 网上关于opencv的安装已经有了不少资料,但是没有一篇资料能让我一次性安装成功,因此花费了大量时间去解决各种意外,希望这篇能给一些人带去便利,节省时间. 1.安装OpenCV所需的库 1 sudo apt-get install build-essential 2 sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavforma

ubuntu14.04安装oracle12c及错误解决方法

1.更换apt源 cp /etc/apt/sources.list /etc/apt/sources.list.bak vim /etc/apt/sources.list cat  /etc/apt/sources.list deb http://mirrors.163.com/ubuntu/ trusty main restricted universe multiverse deb http://mirrors.163.com/ubuntu/ trusty-security main res

ubuntu16.04安装skype

ubuntu16.04安装skype 一句命令搞定 wget https://repo.skype.com/latest/skypeforlinux-64.deb && sudo dpkg -i skypeforlinux-64.deb 从网页下载 https://www.skype.com/en/get-skype/ 混乱的官网 百度和Bing搜索skype,第一个出来的是skype.gmw.cn这个网站.这个网站上没有提供ubuntu版skype,让人怀疑skype是不是不支持ubun