Eclipse:Failed to load the JNI shared library 解决方法

错误截图:

解决方法:

应该是java版本的问题和位数的问题

Eclipse打开后出现这个问题,查阅相关资料后发现是安装的java是32bit的和系统、Eclipse 64bit不一致

解决方法:

保留了原来的32bit的java,同时又安装了一个64bit的java

效果图如下:

jdk: C:\Program Files (x86)\Java\jdk1.8.0_11

jre:  C:\Program Files (x86)\Java\jre8\

上面这个是和系统不兼容的,所以又改成了下面这个版本,是64bit

路径:C:\Program Files\Java\jdk1.7.0_67

重新设置JAVA_HOME后,问题解决。

时间: 09-07

Eclipse:Failed to load the JNI shared library 解决方法的相关文章

启动 Eclipse 弹出“Failed to load the JNI shared library jvm.dll”错误的解决方法!

启动 Eclipse 弹出"Failed to load the JNI shared library jvm.dll"错误的解决方法 http://blog.csdn.net/zyz511919766/article/details/7442633   原因1:给定目录下jvm.dll不存在. 对策:(1)重新安装jre或者jdk并配置好环境变量.(2)copy一个jvm.dll放在该目录下. 原因2:eclipse的版本与jre或者jdk版本不一致 对策:要么两者都安装64位的,要

启动Eclipse 弹出“Failed to load the JNI shared library”错误的解决方法

原因1:eclipse的版本与jre或者jdk版本不一致 对策:要么两者都安装64位的,要么都安两个是32位一个是64位. 原因2:给定目录下jvm.dll不存在 对策:(1)重新安装jre或者jdk并配置好环境变量.(2)copy一个jvm.dll放在该目录下. 原因1的概率更大一些,原因2不太可能发生. 启动Eclipse 弹出"Failed to load the JNI shared library"错误的解决方法,布布扣,bubuko.com

Eclipse运行时提示“Failed to load the JNI shared library /Java/jre6/bin/client/jvm.dll”的一个解决方案

出现这个问题的一个原因是eclipse需要的32位jdk,你的环境变量中配的是64位jdk 于是有人建议,重装个32位的jdk,把环境变量换成32位的jdk,但如果你的其它程序需要64位jdk的话,这肯定不是一个好办法 还有一种方法是在 eclipse根目录下有个eclipse.ini文件,添加个 -vm参数 -vm C:/Java32/jdk1.7.0_45/bin/javaw.exe      //这是我的32位jdk 注意位置 -startup plugins/org.eclipse.eq

Eclipse启动 报错[Failed to load the JNI shared library jvm.dll

准备要做java服务器,在安装开发环境时,启动Eclipse报错[Failed to load the JNI shared library jvm.dll] 研究了下,造成错误的原因是由于eclipse与jdk的不一致造成的. 我的开发环境是64位windows8 Pro,安装了64位jdk1.6,eclipse却粗物的安装了32位的版本,由于64位和32位匹配不一致,造成了以上错误的发生. 又尝试了一下,32位jdk+64位eclipse也会发生同样的问题. 好了,解决方法很简单,jdk和e

启动eclipse时出现“Failed to load the JNI shared library jvm.dll”错误及解决

昨晚安装另一个版本的eclipse,启动时出现了"Failed to load the JNI shared library jvm.dll"错误: 1.刚开始以为是因为当时没有将旧版本删除干净,于是就找了原来的安装目录,并没有发现残留的配置文件以及启动文件什么的: 2.于是猜测,新安装的这个版本目录下没有jvm.dll这个文件,可是发现是存在的: 路径1:C:\Program Files (x86)\Java\jre6\bin\client\jvm.dll(该路径下安装的是32位的J

Android学习笔记——eclipse打开后出现Failed to load the JNI shared library .. \jvm.dll 问题

Failed to load the JNI shared library是eclipse没有哦加载到jvm.dll文件 原因有两个: 1.系统环境变量没有配置好,重新安装jre和jdk,并配置好环境变量 JAVA_HOME=C:\Program Files\Java\jdk1.7.0_17 class_path=.;%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar; path=%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin

eclipse启动时弹出Failed to load the JNI shared library jvm.dll的Java错误

原因1:给定目录下jvm.dll不存在. 对策:(1)重新安装jre或者jdk并配置好环境变量.(2)copy一个jvm.dll放在该目录下. 原因2:eclipse的版本与jre或者jdk版本不一致 对策:要么两者都安装64位的,要么都安装32位的,不能一个是32位一个是64位. 原因2的概率更大一些,原因1不太可能发生 eclipse启动时弹出Failed to load the JNI shared library jvm.dll的Java错误,布布扣,bubuko.com eclipse

启动Eclipse 弹出"Failed to load the JNI shared library jvm.dll"错误

启动Eclipse 弹出"Failed to load the JNI shared library jvm.dll"错误,如下 原因:eclipse的版本与jre或者jdk版本不一致 解决方法:两者安装的版本需要一致,需同为32位或者同为64位,不能一个为32(64)位,一个为64(32)位.

JAVA-ADT:Failed to load the JNI shared library完美解决

[问题] 运行Android的ADT,即Eclipse出错:Failed to load the JNI shared libraryC:\Program Files (x86)\Java\jre6\bin\client\jvm.dllFailed to load the JNI shared library 其中背景是: 1.之前已经可以正常运行的,即已经正常安装了JRE6的. 2.后来删除掉了JRE6了. 3.刚刚又去重新安装了JRE6,结果还是错误依旧. 4.并且已经确定了:C:\Prog