CDH安装HDFS的依赖ZooKeeper问题

安装HDFS时,需要安装ZooKeeper,安装完了3个节点,始终有问题。

刚开始,运行良好

过了一段时间后,

问题出现了!

=================================================

定位问题

看来至少时钟偏差有问题。

检查机器,发现这3台机器的ntp服务都未开启,赶紧开启。

参考:

http://www.cnblogs.com/liuyou/archive/2012/07/29/2614341.html

http://www.aboutyun.com/thread-9087-1-1.html

================

发现以下问题

原来是使用“ntpdc -c loopinfo”来测试NTP

然后在我的3台机器上轮流执行这个命令,果然有1台机器有问题:

这就奇怪了!

http://support.ntp.org/bin/view/Support/KnownOsIssues看到

最后换了一台机器搞定。

时间: 10-25

CDH安装HDFS的依赖ZooKeeper问题的相关文章

安装软件时依赖冲突的万能解决方案

Perface 如果让你实现这个页面和一些操作的,比如点击1.2.3等就在那个input text中显示,还有删除功能,拨打我们先不要管它,只是模拟而已.要是我刚开始做的话,我会这样做: 用css.HTML布局那个界面 用javascript的事件委托监听那个按钮的父节点的点击事件 但是如果我想用面向对象的思想做呢?我是用Ext做的,所以我想说的是它帮我封装了很多.可能一些没用过Ext的人不太了解我下面贴的代码,但是我会尽量解释清楚的! Description ContactTelPanel =

ubuntu采用apt-get安装软件出现依赖问题的解决方案

ubuntu采用apt-get安装软件出现依赖问题的解决方案 ubuntu采用apt-get安装软件出现依赖问题的解决方案 1:ubuntu采用apt-get安装软件原则上是不会出现包依赖的问题的,出现这种问题大多是"源"的问题,需要你更新一下源 2:更新源 #sudo apt-get update 5:再次用apt-get安装软件就可以了,亲测成功 例如:下面是Ubuntu 12.0.4 下安装SSH时出现 依赖问题 如图片: 第二步:#sudo apt-get update 第三步

CentOS6.5 安装Python 的依赖包

1.CentOS6.5 安装Python 的依赖包 yum groupinstall "Development tools"yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel 2.下载Python3.5的源码包并编译 wget https://www.p

rpm包安装过程中依赖问题“libc.so.6 is needed by XXX”解决方法

rpm包安装过程中依赖问题"libc.so.6 is needed by XXX"解决方法 折腾了几天,终于搞定了CentOS上的Canon LBP2900打印机驱动.中间遇到了一些问题,主要是安装rpm包出现的依赖问题,费尽周折总算是解决了.现在简单总结一下. 首先说明一下,我用的CentOS版本是6.6,64位.打印机驱动程序是两个rpm安装包:cndrvcups-common-2.60-1.x86_64.rpm和cndrvcups-capt-2.60-1.x86_64.rpm.

【转载】如何自动生成和安装requirements.txt依赖

如何自动生成和安装requirements.txt依赖 在查看别人的Python项目时,经常会看到一个requirements.txt文件,里面记录了当前程序的所有依赖包及其精确版本号.这个文件有点类似与Rails的Gemfile.其作用是用来在另一台PC上重新构建项目所需要的运行环境依赖. requirements.txt可以通过pip命令自动生成和安装 生成requirements.txt文件 pip freeze > requirements.txt 安装requirements.txt依

yum安装centos系统依赖库

安装centos系统依赖库,安装软件过程中,经常需要的一些库,可以在编译安装软件前执行如下命令: 首先更新系统(这步可以不执行) yum -y update 预安装 编译器及库文件 yum -y install make cmake gcc g++ gcc-c++ gcc-g77 libtool autoconf automake imake libxml2-devel expat-devel yum -y install ncurses ncurses-devel pcre pcre-deve

CentOS7 命令行安装teamviewer遇到依赖包问题及完美解

公司新到了几台服务器做Docker集群方面的应用,将这几台服务器搭建成一个集群.由于要经常同时操作这几台服务器,而我又不喜欢待在机房.TeamViewer很好的解决了该问题,Teamviewer可实现远程控制电脑,并可在你自己的电脑上同时控制几台台服务器,操作起来相当方便. ? 一.CentOS7命令行安装TeamViewer ? 1.进入官网下载软件包 2.安装 #?yumyum?install?-y?teamviewer_13.0.5693.x86_64.rpm ? ? 或者? #?rpm?

如何自动生成和安装requirements.txt依赖

在查看别人的Python项目时,经常会看到一个requirements.txt文件,里面记录了当前程序的所有依赖包及其精确版本号.这个文件有点类似与Rails的Gemfile.其作用是用来在另一台PC上重新构建项目所需要的运行环境依赖. requirements.txt可以通过pip命令自动生成和安装 生成requirements.txt文件 pip freeze > requirements.txt 安装requirements.txt依赖 pip install -r requirement

[Liunx]apt-get安装软件:依赖冲突问题及解决

正常使用apt-get install安装出现依赖冲突问题: 大概是这样: [email protected]:~$ sudo apt-get install gcc-5-base:i386 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 gcc-5-base:i386 已经是最新版 (5.4.0-6ubuntu1~16.04.11). gcc-5-base:i386 已设置为手动安装. 您可能需要运行"apt-get -f install"来