阿里云服务器的坑=====部署EF+MVC

异常处理汇总 ~ 修正果带着你的Net飞奔吧!http://www.cnblogs.com/dunitian/p/4599258.html

先参考:http://www.cnblogs.com/dunitian/p/4981572.html

网站部署好后==>继续404

网站日记如下:

2015-11-19 23:51:52,119 [15] ERROR log - System.InvalidOperationException: 未找到具有固定名称“System.Data.SqlClient”的 ADO.NET 提供程序的实体框架提供程序。请确保在应用程序配置文件的“entityFramework”节中注册了该提供程序。有关详细信息,请参阅 http://go.microsoft.com/fwlink/?LinkId=260882。
在 System.Data.Entity.Infrastructure.DependencyResolution.DefaultProviderServicesResolver.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.CachingDependencyResolver.<>c__DisplayClass1.<GetService>b__0(Tuple`2 k)
在 System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
在 System.Data.Entity.Infrastructure.DependencyResolution.CachingDependencyResolver.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.ResolverChain.<>c__DisplayClass3.<GetService>b__0(IDbDependencyResolver r)
在 System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
在 System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
在 System.Data.Entity.Infrastructure.DependencyResolution.ResolverChain.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.RootDependencyResolver.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.ResolverChain.<>c__DisplayClass3.<GetService>b__0(IDbDependencyResolver r)
在 System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
在 System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
在 System.Data.Entity.Infrastructure.DependencyResolution.ResolverChain.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.CompositeResolver`2.GetService(Type type, Object key)
在 System.Data.Entity.Infrastructure.DependencyResolution.DbDependencyResolverExtensions.GetService[T](IDbDependencyResolver resolver, Object key)
在 System.Data.Entity.Utilities.DbProviderFactoryExtensions.GetProviderServices(DbProviderFactory factory)

System.Data.SqlClient ==>去项目中找没看见,估计就是不完全支持ef,或者dal层有问题,后来看见dal层有个EntityFramework.SqlServer.dll 发布的bin里面并没有,于是copy了一个,就可以了。。。。。

这个是阿里云木有的一些dll

ok了~

www.dkill.net

时间: 11-19

阿里云服务器的坑=====部署EF+MVC的相关文章

阿里云服务器Centos6.5 部署JDK+TOMCAT+MYSQL

最近公司申请台阿里云服务器,选择的java多功能部署环境.登陆才发现,除了mysql装了,apache-tomcat.jdk-8u25-linux只有源文件.切换到/root/soft目录下,可以看到源文件.下面是部署jdk+apache,并测试生产环境. 一.部署JDK 查看系统是否安装了JDK:java –version(或者rpm -qa |grep java) 这里没预装,于是复制jdk-8u25-linux-x64.tar.gz到/usr/java (cp jdk-8u25-linux

基于阿里云服务器Linux系统部署JavaWeb项目(一)

前段时间刚完成一个JavaWeb项目,想着怎么部署到服务器上,边学边做,花了点时间终于成功部署了,这里总结记录一下过程中所遇到的问题及解决方法.之所以选择阿里云,考虑到它是使用用户最多也是最广泛的云服务器.学生可以选择学生机,价格非常优惠.本人选择的是系统镜像:CentOS 7.3 64位. 根据需要部署了以下环境: 1.配置Java环境 2.安装Tomcat及配置.war包部署 3.安装MySql及配置.运行sql文件 准备工作: 1.首先需要开通项目用到的端口,例如8080端口,下图为本人开

阿里云服务器Centos6.5 部署SVN

开发要求部署个版本管理器,参照教程,写写自己的经验: 检查是否安装了低版本的SVN[[email protected] /]# rpm -qa subversion #卸载旧版本SVN[[email protected] modules]# yum remove subversion安装SVN [[email protected] modules]# yum install httpd httpd-devel subversion mod_dav_svn mod_auth_mysql确认已安装了

Nginx+Uwsgi+Flask在阿里云服务器上的部署

先说明一下,我用的系统是centos6.8,个人感觉centos的系统配置还是挺简单的...不过存在很多防火墙的问题,下边一步步来说.... centos上应该是默认已经安装了Python2.6,不过你要想安装其他的版本就需要自己首先安装一个pyenv的东西.... 1.先说一下pyenv吧,这是一个多版本共存的版本管理器.windows上就不用说了,可以安装多个版本的Python,但是Linux上就会有问题了,所以需要这么一个管理器. 第一步,安装: # curl -L https://raw

阿里云服务器Centos6.5 部署多版本tomcat

线上很多要求是启动多个tomcat,其实就是配置不同端口,启动tomcat时以不同端口识别服务. 前文已经介绍了如何安装部署tomcat,此处只明确指出不同之处: 1.修改环境变量 vim /etc/profile,添加如下内容: export TOMCAT_HOME=/usr/tomcatexport TOMCAT_2_HOME=/usr/tomcat8export CATALINA_BASE=/usr/tomcatexport CATALINA_2_BASE=/usr/tomcat8expo

阿里云服务器Web Deploy配置和使用Visual Studio进行Web项目发布部署遇到的坑

阿里云的服务器一直闲着,烧着银子,当初花几千大洋开通,本想弄信息化的项目为所帮扶的贫困户脱贫助手,不想势单力薄,一直没有找到好的项目.最近大家都在众志成城抗击新肺疫情,于是又想能不能尽点自己的力量,于是又开始打开Visual Studio 鼓捣起项目来,为了测试与微信服务器的消息发送,每次都得把项目发布到阿里的去服务器上,由于以前一直没怎么用,发布的方法是采用最原始的复制,然后远程桌面粘贴上去.次数多了感觉太累了,比较的方法,一个是FTP方式,另一个是Web Deploy,FTP方式虚拟主机一直

如何把php项目部署到阿里云服务器window server2012__含公网ip访问时jquery/ajax失效解决办法

记一次蛋疼的折腾. 弄了一晚上最后发觉是360浏览器的问题,换个浏览器就好了.垃圾360用什么IE7文档模式.导致界面和功能失效. 建议大家测试的时候用firefox或者chrome. 项目部署到服务器后360浏览器兼容模式显示错误的解决办法:http://www.cnblogs.com/zj917/p/6697724.html -------------------------------------------------- 正文: 上篇博客说临时起意做了个有意思的聊天版,就想把它部署到阿里

阿里云服务器 ECS 部署lamp:centos+apache+mysql+php安装配置方法 (centos7)

1.效果图 1 2. 部署步骤 1 1. mysql安装附加(centos7) 7 3.错误注意****** 10 1.效果图 2.部署步骤 链接 http://jingyan.baidu.com/article/870c6fc31218e8b03fe4be16.html 首先安装apachecentos可以直接yum安装apache ?. 命令:yum install httpd ? //根据提示,输入Y安装即可成功安装? 然后启动apache,并且设置系统让?Apache 开机自动启动. 命

阿里云服务器Linux配置数据库、jre、tomcat、部署javaweb

1.VPSMate安装 # wget http://www.vpsmate.org/tools/install.py # python install.py 2.安装好了VPSMate后,还要安装IUS源,执行以下命令(注意版本): yum -y install gcc yum -y install gcc-c++ rpm -ivh http://dl.iuscommunity.org/pub/ius/stable/Redhat/6/i386/ius-release-1.0-11.ius.el6