公司来了一个奇葩需求pppoe client+server+EOIP+vlan

1、PPPOE SERVER在上海,有多根ADSL,不同的ADSL有不同的vlan对应不同的帐号

2、北京的ROS和上海的ROS用EOIP,在IP基础上创建桥接隧道

3、北京的ROS上同时建立PPPOE SERVER

4、北京ROS和PC机器在一个二层网络里,PC机器可以通过PPPOE拨号到北京的ROS,我们设定PPPOE的帐号密码跟上海的PPPOE帐号密码一样,一一对应。

5、北京ROS上面,eoip创建好以后,在eoip上创建不同的vlan编号,在北京的ROS上通过不同的vlan,不同的帐号密码,拨号不同的ADSL

6、PC机器PPPOE拨号成功以后,同时北京的ROS对应的PPPOE拨号也拨号;PC机器PPPOE退出以后,同时北京的ROS对应的PPPOE拨号也退出。

拓扑图如下:

上海这边的路由器配置:

/interface bridge
add name=bridge1-lan
add name=bridge2-wan
/interface ethernet
set [ find default-name=ether1 ] name=ether1-wan
set [ find default-name=ether2 ] name=ether2-vlan2
set [ find default-name=sfp1 ] disabled=yes
/interface eoip
add local-address=192.168.2.99 mac-address=02:CF:80:02:C1:17 name=\
eoip-tunnel1 remote-address=192.168.13.253 tunnel-id=22
/interface vlan
add interface=bridge2-wan name=vlan37 vlan-id=37
add interface=bridge2-wan name=vlan38 vlan-id=38
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1-lan interface=ether3
add bridge=bridge1-lan interface=ether4
add bridge=bridge1-lan interface=ether5
add bridge=bridge2-wan interface=ether1-wan
add bridge=bridge2-wan interface=eoip-tunnel1
/ip address
add address=192.168.2.99/24 interface=ether2-vlan2 network=192.168.2.0
/ip route
add distance=1 dst-address=192.168.0.0/16 gateway=192.168.2.201

北京这边的路由器配置:

/interface bridge add name=bridge1-lan
/interface eoip add mac-address=02:CD:94:16:20:95 name=eoip-tunnel1 remote-address=192.168.2.99 tunnel-id=22
/interface vlan add interface=eoip-tunnel1 name=vlan37 vlan-id=37
/interface vlan add interface=eoip-tunnel1 name=vlan38 vlan-id=38
/interface pppoe-client add interface=vlan37 name=pppoe-out-vlan37 password=85582349 user=02585582349
/interface pppoe-client add interface=vlan38 name=pppoe-out-vlan38 password=85582354 user=02585582354
/ppp profile add dns-server=114.114.114.114 name=profile-pppoe on-down=":local u \$user\r\
\ninterface pppoe-client disable [find user=\$u]\r\
\n" on-up=":local u \$user\r\
\ninterface pppoe-client enable [find user=\$u]\r\
\n" only-one=yes
/interface bridge port add bridge=bridge1-lan interface=ether1
/interface bridge port add bridge=bridge1-lan interface=ether2
/interface bridge port add bridge=bridge1-lan interface=ether3
/interface bridge port add bridge=bridge1-lan interface=ether4
/interface bridge port add bridge=bridge1-lan interface=ether5
/interface pppoe-server server add disabled=no interface=bridge1-lan one-session-per-host=yes service-name=pppoe-server
/ip address add address=192.168.13.253/24 interface=bridge1-lan network=192.168.13.0
/ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=02585582349 passthrough=no src-address=100.10.1.1
/ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=02585582354 passthrough=no src-address=100.10.1.2
/ip firewall nat add action=masquerade chain=srcnat out-interface=all-ppp
/ip route add distance=1 gateway=pppoe-out-vlan37 routing-mark=02585582349
/ip route add distance=1 gateway=pppoe-out-vlan38 routing-mark=02585582354
/ip route add distance=1 dst-address=192.168.0.0/16 gateway=192.168.13.254
/ppp secret add local-address=100.10.1.254 name=02585582354 password=85582354 profile=profile-pppoe remote-address=100.10.1.102 service=pppoe
/ppp secret add local-address=100.10.1.254 name=02585582349 password=85582349 profile=profile-pppoe remote-address=100.10.1.101 service=pppoe

原文地址:https://www.cnblogs.com/itfat/p/12707513.html

时间: 04-15

公司来了一个奇葩需求pppoe client+server+EOIP+vlan的相关文章

[nginx]nginx的一个奇葩问题 500 Internal Server Error phpstudy2018

[nginx]nginx的一个奇葩问题 500 Internal Server Error 解决方案 nginx 一直报500 Internal Server Error 错误,配置是通过phpstudy2018站点域名管理生成的. 默认是  root   "D:\php\phpstudy\PHPTutorial\WWW\foxphp"; 修改成这样就好了 root   "D:\\php\\phpstudy\\PHPTutorial\\WWW\\foxphp"; 查

2.3为方便旅客,某航空公司拟开发一个机票预定系统。 写出问题定义并分析系统的可行性。

为方便旅客,某航空公司拟开发一个机票预定系统.旅行社把预定机票的旅客信息(姓名.性别.工作单位.身份证号码.旅行时间.旅行目的地等)输入进 入该系统,系统为旅客安排航班,印出取票通知和账单,旅客在飞机起飞的前一天凭取票通知和账单交款取票,系统校对无误即印出机票给旅客. 写出问题定义并分析系统的可行性. 1>     目标:在一个月内建立一个高效率,无差错的航空公司机票预定系统 2>     存在的主要问题:人工不易管理,手续繁琐 3>     建立新系统 ①  经济可行性        

一个奇葩的悖论

前言 说到集合就不得不提到康拓,虽说集合论对现代数学有着非常大的影响,但总是对他的无限集的理论有一些疑问(不知道是不是叫无限集,反正我是这么叫).最简单的例子就是一个平面上点的数量与一条直线上点的数量一样多(这是人第一次听到都会觉得不对吧).该问题普遍的解释一般是说这两者的元素之间有一一对应的关系(好比是你有啥我就有啥).所以我就针对这个问题发表来一个奇葩的悖论. 主干 首先我们来看一下圆锥与圆柱.小学里就知道圆锥的体积是圆柱的1/3,可换一个角度想想,如果都把圆锥与圆柱沿水平方向切成无限份,那

寻找以下公司的实际控制人。有合作需求。

寻找以下公司的实际控制人.有合作需求.北京中科奥森科技有限公司北京文安智能技术股份有限公司北京天睿空间科技股份有限公司北京东方红海科技发展有限公司北京信路威科技股份有限公司杭州图酷科技有限公司成都臻识科技发展有限公司广东微模式软件股份有限公司杭州正非科技有限公司亮风台(上海)信息科技有限公司北京智慧星光信息技术有限公司红麦聚信(北京)软件技术有限公司北京明略软件系统有限公司北京西盈信息技术有限公司北京中科翔龙科技有限公司北京瀚思安信科技有限公司厦门市巨龙软件工程有限公司上海英迈吉东影图像设备有限

一个渲染需求

用unity3d做游戏也有一段时间了,这周有一个渲染的需求,用到的技术不算很深,但确实也比较繁琐,值得记录一下. 需求大概是这样的,有四层图,我们称为A,B,C,D四层.他们的Blend顺序是A->B->C->D,其中C对D的Blend算法使用的是PS中的叠加算法,B->C,D是替换,A->B,C,D也是PS的叠加.这个问题的难点在于两部分:第一,有部分层的Blend算法是使用的PS的叠加,而叠加公式为(B < 128) ? (2 * A * B / 255):(255

PPTP&amp;L2TP&amp;PPPOE client and server configure

一. PPPOE 1. server(参考http://laibulai.iteye.com/blog/1171898) (1)安装rp-pppoe:yum install rp-pppoe (2)配置 /etc/ppp/pppoe-server-options,内容: # PPP options for the PPPoE server# LIC: GPLrequire-paprequire-chaploginlcp-echo-interval 10lcp-echo-failure 2logf

一个奇葩问题,jQuery的chzn-select查询失效

之前遇到了一个奇葩问题,jQuery的chzn-select查询失效.本来用jQuery的chosen,挺好用的,这个select可以自动查询匹配,比select2用得更方便. 可是,有的地方用得却无法查询,有的地方又可以,查找了好久还是找不出来原因.用了firebug,又查代码,费了很大周折,最后还是发现了问题了. 原来的代码是这样的 <td> <select class="chzn-select" id="industryId" name=&q

如何做一个软件需求分析师(转来的)

这篇不想再去重复一个软件需求分析员的知识体系结构,而是挑重点来谈下成为一个合格的软件需求分析人员的关键点. 我原来对软件需求的定义或描述更多是偏于对现实世界的定义,而对软件架构的描述为现实到实现之间的第一层抽象.在这里纠正 一下即:用户需求是对现实世界的定义,而 软件系统需求是现实到实现的第一层抽象,即业务建模和软件系统用例建模.在原来的软件工程里面我们更多谈到的一个词是系统分析员,我现在将其拆分为了软件 需求BA和系统架构SA两个角色.而实际上一个真正优秀的软件需求人员必须具备两方面的能力.

NetMQ(ZeroMQ)Client =&gt; Server =&gt; Client 模式的实现

ØMQ (也拼写作ZeroMQ,0MQ或ZMQ)是一个为可伸缩的分布式或并发应用程序设计的高性能异步消息库.它提供一个消息队列, 但是与面向消息的中间件不同,ZeroMQ的运行不需要专门的消息代理(message broker).该库设计成常见的套接字风格的API. ZeroMQ是由iMatix公司和大量贡献者组成的社群共同开发的.ZeroQ通过许多第三方软件支持大部分流行的编程语言 .类库提供一些套接字(对传统Berkeley套接字和Unix domain socket的泛化),每一个套接字可