Ubuntu下编译安装QEMU

Ubuntu下编译安装QEMU

由于环境需求,今天在ubuntu14.04的环境下手动编译安装了QEMU2.1.2。

QEMU下载地址:http://wiki.qemu-project.org/download/qemu-2.1.2.tar.bz2

具体下载及解压步骤这里就不在赘述了,主要就是说下环境准备的一些依赖包,编译QEMU最重要的就是gcc,所以我们要先把gcc安装上。

[email protected]:~# apt-get install gcc-3.4 cpp-3.4

安装QEMU需要SDL开发库支持,还需要安装zlib和ESD:

[email protected]:~# apt-get install zlib1g-dev zlib1g-dbg libesd0-dev automake

到此为止安装QEMU的前提依赖条件咱们已经解决完毕,下面可以开始编译安装了。

[email protected]:~# cd qemu-2.1.2/
[email protected]:~# ./configure
[email protected]:~# make && make install

make的时间非常慢,我计算过大约1个小时左右。

下面说下我在编译QEMU的过程中遇到的问题以及解决办法:

报错类型:
make: *** [/root/qemu-2.1.2/pixman/configure] Error 127

解决方法:
apt-get install -y automake

时间: 12-24

Ubuntu下编译安装QEMU的相关文章

Linux下编译安装qemu和libvirt

目录 [hide] 1 安装qemu 1.1 qemu介绍 1.2 下载源文件 1.3 编译安装 2 安装libvirt 2.1 libvirt介绍 2.2 下载libvirt 2.3 编译安装 3 参考资料 KVM虚拟机(英语:Kernel-based Virtual Machine),是一种用于Linux内核中的虚拟化基础设施.KVM目前支援Intel VT及AMD-V的原生虚拟技术.KVM在2007年2月被导入Linux 2.6.20核心中.它也被引入FreeBSD.在Mac OS X中,

Ubuntu 下编译安装linux

1. 准备工作切换为管理员权限,sudo –i 输入用户密码 进入root 权限apt-get install build-essential kernel-package libncurses5-dev libqt3-headersbuild-essential (基本的编程库(gcc, make 等)kernel-package (Debian 系统里生成 kernel-image 的一些配置文件和工具)libncurses5-dev (meke menuconfig 要调用的) libqt

一、Ubuntu下编译安装Mysql5.0.45

一.编译安装Mysql5.0.45 在Ubuntu下搭建LNMP环境.编译安装mysql,nginx,php.最后在LNMP前提下安装composer,并且安装laravel框架.首先,第一步开始编译安装Mysql. 步骤: cd /usr/local/src,进入到文件夹中,这个文件夹用来保存所需使用的软件安装包. 接着键入"sudo wgethttp://downloads.mysql.com/archives/mysql-5.0/mysql-5.0.45.tar.gz"回车,如果

二、Ubuntu下编译安装Nginx1.8.0

    在Ubuntu下搭建LNMP环境.编译安装mysql,nginx,php.最后在LNMP前提下安装composer,并且安装laravel框架.首先,第二步开始编译安装Nginx1.8.0 1.先进入"/usr/local/src"文件夹中,接着键入 "sudo wget http://nginx.org/download/nginx-1.8.0.tar.gz"回车,等待下载完毕.下载完毕后,执行"sudo tar zxvf nginx-1.8.0

二、Ubuntu下编译安装PHP5.6.16

    在Ubuntu下搭建LNMP环境.编译安装mysql,nginx,php.最后在LNMP前提下安装composer,并且安装laravel框架.首先,第三步开始编译安装PHP5.6.16 1.先进入"/usr/local/src"文件夹中,接着键入 "sudo wget http://cn2.php.net/distributions/php-5.6.16.tar.gz"回车,等待下载完毕.下载完毕后,执行"sudo tar zxvf php-5.

三、Ubuntu下编译安装PHP5.6.16

    在Ubuntu下搭建LNMP环境.编译安装mysql,nginx,php.最后在LNMP前提下安装composer,并且安装laravel框架.首先,第三步开始编译安装PHP5.6.16 1.先进入"/usr/local/src"文件夹中,接着键入 "sudo wget http://cn2.php.net/distributions/php-5.6.16.tar.gz"回车,等待下载完毕.下载完毕后,执行"sudo tar zxvf php-5.

ubuntu下编译安装php

依赖库: sudo apt-get install autoconf sudo apt-get install libxml2-dev sudo apt-get install bzip2 sudo apt-get install libcurl3-openssl-dev sudo apt-get install libcurl4-gnutls-dev sudo apt-get install libjpeg-dev sudo apt-get install libpng-dev sudo ap

Ubuntu 下编译安装Bundler

参考转自http://www.cnblogs.com/weizhoupan/archive/2011/03/08/1977366.html 编译安装,因为编译过程中遇到了一些问题,将自己的经验总结一下! 一.Bundler源码包获取 利用Noah Snavely提供的源码包,网址:http://www.cs.cornell.edu/~snavely/bundler/ .(自己下载的是:bundler_sfm-master.tar.gz) 二.安装python 源码中utils/bundler.p

ubuntu下编译安装mysql记录

搞了整整一天,好不容易折腾完,在此记录下,下次就省事了.     去官网http://www.php.net/downloads.php下载所需要的php版本,这里我选择5.6.22.     下载:    wget http://cn2.php.net/distributions/php-5.6.22.tar.gz     解压:    tar -zxvf  php-5.6.22.tar.gz && cd php-5.6.22    configure脚本:     /configure