LNMP与Zabbix4.0 环境部署

LNMP+Zabbix4.0 环境部署

环境

关闭防火墙,Selinux

systemctl stop firewalld
sed -i 's/SELINUX=enforcing/SELINUX=disabled/g' /etc/selinux/config
setenforce 0

服务端

LNMP环境所需要的安装包如下。主要以rpm包为主。不是源码安装

[[email protected] ~]# rpm -qa | grep nginx
nginx-1.16.0-1.el7.ngx.x86_64
[[email protected] ~]# rpm -qa |grep php
php-common-5.4.16-46.el7.x86_64
php-5.4.16-46.el7.x86_64
php-cli-5.4.16-46.el7.x86_64
php-fpm-5.4.16-46.el7.x86_64
php-pdo-5.4.16-46.el7.x86_64
php-mysql-5.4.16-46.el7.x86_64
[[email protected] ~]# rpm -qa | grep mysql
mysql-community-common-5.7.26-1.el7.x86_64
mysql-community-release-el7-7.noarch
mysql-community-libs-5.7.26-1.el7.x86_64
mysql-community-server-5.7.26-1.el7.x86_64
mysql-community-client-5.7.26-1.el7.x86_64
mysql-community-libs-compat-5.7.26-1.el7.x86_64

详细的LNMP搭建参考:LNMP搭建详解

安装zabbix

rpm -Uvh https://repo.zabbix.com/zabbix/4.0/rhel/7/x86_64/zabbix-release-4.0-1.el7.noarch.rpm
yum clean all
yum -y install zabbix-server-mysql zabbix-web-mysql zabbix-agent zabbix-get zabbix-web zabbix-sender

## failed to link /usr/share/zabbix/fonts/graphfont.ttf -> /etc/alternatives/zabbix-web-font: No such file or directory

## 进行解决
## 在windows里面找一个显示中文的字体文件复制到服务器中

mkdir /usr/share/zabbix/fonts
mv SIMHEI.TTF /usr/share/zabbix/fonts/graphfont.ttf
ln -s /usr/share/zabbix/fonts/graphfont.ttf /etc/alternatives/zabbix-web-font

创建,配置zabbix

1.创建zabbix库,并授权用户

mysql -uroot -p123456
mysql> create database zabbix character set utf8 collate utf8_bin;
mysql> grant all privileges on zabbix.* to [email protected]'%' identified by '123456';
msyql> flush privileges

2.解压zabbix数据库文件并导入数据库

gunzip /usr/share/doc/zabbix-server-mysql*/create.sql.gz

# 方法1:
mysql -uroot -p zabbix >/usr/share/doc/zabbix-server-mysql*/create.sql

# 方法2:
mysql -uroot -p123456
mysql> use zabbix;
mysql> source create.sql的路径;
mysql> show tables;

# 方法3:
zcat /usr/share/doc/zabbix-server-mysql*/create.sql.gz | mysql -uzabbix -p zabbix

# 移动文件到web根目录
cp -rp /usr/share/zabbix/ /usr/share/nginx/html/

启动各项服务

systemctl restart mysqld nginx zabbix-server.service  zabbix-agent.service php-fpm
systemctl enable mysqld nginx zabbix-server.service  zabbix-agent.service php-fpm

访问网页,从网页进行安装

出现上图,按照要求进行设置相关配置文件

主要的配置文件有:

  • /etc/php.ini
  • /etc/httpd/conf.d/zabbix.conf

当全部为绿色后就可以进行下一步

登录的时候,默认账户名Admin,密码zabbix

参考文献:zabbix安装官方参考
参考文献:zabbix图像配置参考

解决zabbix乱码问题

没有任何显示或者显示人看不懂的,表明存在乱码,需要进行解决
1.在window拷贝一个能显示中午的字体文件到zabbix-server的/usr/share/zabbix/fonts目录下面,注意字体文件的权限
2.制作字体文件名改为graphfont.ttf软连接

mv /usr/share/nginx/html/zabbix/fonts/SIMHEI.TTF ./fonts/graphfont.ttf

3.重启服务

systemctl restart zabbix-agent.service zabbix-server.service nginx php-fpm.service mysqld.service 

解决Zabbix server is not running :the information displayed may not be current.

在登录了zabbix首页之后,可能在底部会出现
Zabbix server is not running :the information displayed may not be current.

可能出现的原因:

  • 防火墙阻止了nginx服务
  • 数据库授权有问题
  • zabbix的web配置文件配置问题
  • dns的解析问题

1.防火墙

# 关闭防火墙和selinux
systemctl status firewalld
systemctl stop firewalld
systemctl disabled firewalld

# 关闭selinux
setenforce 0   # 临时关闭
sed -i '/^SELINUX=/cSELINUX=disabled' /etc/selinux/config

2.更改zabbix的web配置文件
配置文件名:zabbix.conf.php
可以通过find / -name "zabbix.conf.php"查找,之后按照下图进行修改

3.数据库授权
一般问题不会在这,因为安装之前已经授权了,但由于刚才修改了web文件,需要重新授权

mysql -uroot -p123456
mysql> grant all privileges on zabbix.* to [email protected]'%' identified by 123456;
mysql> flush privileges;
mysql> exit

4.检查dns,并修改
1.修改DNS
vim /etc/hosts
2.重启nginx
systemctl restart nginx

5.检查配置文件

vim /etc/zabbix/zabbix_server.conf
DBHost=192.168.50.66
DBName=zabbix
DBUser=zabbix
DBPassword=123456

6.重启服务
systemctl restart zabbix-agent.service zabbix-server.service nginx php-fpm.service mysqld.service

7.登录web界面
http://192.168.50.66/zabbix

LAMP 与 zabbix 环境部署
LNMP 环境部署
官方安装zabbix文档
官方源码安装zabbix文档

原文地址:https://www.cnblogs.com/moniter/p/12305160.html

时间: 02-15

LNMP与Zabbix4.0 环境部署的相关文章

LNMP(nginx php-fpm mysql) 环境部署——php

前言: 之前已经说过部署的初衷,如有不清楚的,可以看下上篇的前言或在评论区留言给我. 此篇主要介绍安装php,php会要用到mysql连接数据库 准备: php官网:php.net 源码目录:/usr/local/src php采用源码安装方式 系统为:centos 6.8 php采用5.6版本.最新版本为7版本,如是新项目可采用7版本,对于老项目,如没有重构的准备,建议不要升级到7 安装: 1 安装工具,配置编译的时候提示缺少什么就安装什么的开发包 yum install -y wget ma

陇南大全elasticsearch 2.2.0 环境部署

先决条件 依赖java环境 citycloud soft nofile 65536 citycloud hard nofile 65536 citycloud soft memlock unlimited citycloud hard memlock unlimited

lnmp (nginx php-fpm mysql) 环境部署——nginx

前言: 随着业务的发展,原有的单服务器架构已无法支撑现有业务的访问量,经研究决定,对现有服务做拆分,并对应用做横向扩展.目的是为了减轻服务集中造成的压力. 架构: 前端使用nginx作为web服务,后端使用php-fpm作为应用服务,数据库为mysql 应用服务可使用多台服务器做集群 准备工作: 系统为centos 6.8 x64 minimal 1 ip划分 web服务:172.16.10.0/24 应用服务:172.16.20.0/24 数据库服务:172.16.30.0/24 2 更新系统

LNMP(nginx php-fpm mysql) 环境部署——mysql

前言: 上一篇已经说过部署的初衷,如有不清楚的,可以看下上篇的前言或在评论区留言给我. 此篇主要介绍安装mysql的方法,php会要用到mysql连接数据库 准备: mysql官网:mysql.com 源码目录:/usr/local/src mysql官方提供官方库.源码.二进制包三种安装方式.此文会分别介绍官方库.源码包的安装方式,对于二进制包,下载后可直接使用. 此文介绍mysql 5.6 社区版,在下载时不要选择错了 安装: 使用官方库安装: 1 配置mysql.repo vim /etc

CentOS7.X部署Zabbix4.0

环境搭建在CenOS7.X里面部署Zabbix最好先搭建好环境,我这里使用的是PHP+MariaDB+httpd部署的. 部署PHP环境:yum install -y php php-php-fpm修改 PHP 参数以安装 ZABBIX 的安装需求: date.timezone = Asia/Shanghaimax_execution_time = 300post_max_size = 32Mmax_input_time = 300memory_limit = 128Mmakefile启动 PH

LNMP环境部署及zabbix服务器端安装

一.LNMP环境部署 1.配置epel源 建议在系统安装完成之后就配置epel源,方便一些软件包的安装: wget http://mirrors.ustc.edu.cn/centos/6/extras/x86_64/Packages/epel-release-6-8.noarch.rpmrpm -ivhepel-release-6-8.noarch.rpm 2.nginx安装 (1)安装支持软件 Nginx.mysql.php的配置及运行需要pcre.zlib.openssl等软件包的支持,因此

源码编译LNMP+最新版zabbix4.0

LNMP+Zabbix4.0 之前发过一篇LAMP中的zabbix,兴趣使然,研究一下LNMP中源码编译zabbix的搭建.话不多说,直接上环境及操作步骤. 系统 IP 软件列表 centos7 192.168.70.136 nginx1.8/mysql5.7/php7.3/zabbix4.0 zabbix4.0下载地址 https://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/4.0.4/zabbix-4.

Centos7.X LNMP环境部署(非源码)

1.下载新的CentOS-Base.repo #wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-7.repo 2.安装Nginx YUM源中没有Nginx,我们需要增加一个nginx的源nginx.repo vi /etc/yum.repos.d/nginx.repo [nginx]name=nginx repobaseurl=http://nginx.org/packages/cen

WIN 8.1 ASP.NET环境部署(IIS8.0 + VS 2013 + SQL SERVER 2008)

WIN 8.1 ASP.NET环境部署(IIS8.0 + VS 2013 + SQL SERVER 2008) 由于需要调试一份ASP.NET的代码 并且 准备WP8的开发环境,所以将系统升级到Windows 8.1 Pro版,并且选用VS 2013作为开发工具,至于SQL SERVER 2008则是用到比较多的一个数据库版本: 需要工具: Microsoft Windows 8.1 Pro Microsoft Visual Studio 2013 Ultimate Microsoft SQL