java1.8 版本改成 java1.7版本

以前先安装的java1.7 大部分程序应该都是只支持1.7 不支持1.8

但是因为要跑一个别人的项目 要求是java1.8 所以想在电脑上同时装1.7和1.8

到官网上下载1.8 安装

安装完成后 并没有配置环境变量 但是发现Java -version变成1.8了

要默认是1.7的话需要做如下操作:

1.环境变量—系统变量—Path中应该存在C:\ProgramData\Oracle\Java\javapath,把这个删除掉

2.修改注册表中HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft的两项,如下图所示:

并把system path中JAVA_HOME的环境变量改成java1.7所在的目录

这样java -version就变回1.7了

时间: 02-08

java1.8 版本改成 java1.7版本的相关文章

【JAVA环境配置免安装】如何由jdk的安装版本改成非安装版本

背景. 官网一般只提供windows下的exe文件,不提供zip打包文件.有些不愿意使用安装版本. 解决方法 本文以windows 7下安装jdk-6u35-windows-x64.exe为例说明 1. 下载jdk-6u35-windows-x64.exe 2. 创建一个目录命名为jdk6,名称位置随意. 3. 点击jdk-6u35-windows-x64.exe,选择路径为jdk6,继续. 4. 在选择安装路径的时候选择取消,此时免安装版本的文件已经存在于jdk6中.文件目录如下: 5. 此时

解决maven项目将model version改成3.0版本问题

找到项目目录,找到.setting文件 找到org.eclipse.wst.common.project.facet.core.xml文件 修改如下标签 <installed facet="jst.web" version="3.0"/> 重启Eclipse即可生效

复利计算5.0(改成Java版本)与 单元测试

//由于C语言版本不方便单元测试,所以改成了java版本,部分代码如下:import java.util.Scanner; public class FuLi{ public static void main(String[] args) { Scanner scanner=new Scanner(System.in); System.out.println("\n复利计算按 1\n单利计算按 2\n计算筹集的养老金按 3\n计算时间按 4\n计算您要的利率按 5\n计算本利和投资按 6\n计算

hdu 4850 Wow! Such String! 构造 或 欧拉路径并改写成非递归版本

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4850 跟这道题也算是苦大仇深了... 题意:构造一个由26个小写字母组成的.无长度为4的重复子串的字符串(要求出能构造出的最大长度) 符合要求的长度为4的字符串有4^26个 容易猜最大长度是:4^26+3 = 456979 比赛的时候想法是要让各个字母出现得尽量“均匀” 用了一个cnt数组记录26个字母出现的次数 每次都选择出现次数最小的.不与前面重复的字母加上去 然而稍微写得有点歪,最后构造出了长

MFC下debug改成release版本出现问题及解决办法

自己在debug下成功运行了自己写的测试自己写第三方库的程序,这里有用到opencv库,所以同时用到了自己的库和opencv的库,需求因为要进行速度的测试,是想要把debug改成release版本,这里出现了错误改了一天,终于搞定. 这里遇到的错误及解决方法如下: 问题一:出现如下所示错误. 问题二:错误 77 error C1189: #error : Please use the /MD switch for _AFXDLL builds     C:\Program Files (x86)

远成文件的版本控制系统~~~浅析

远成文件的版本控制系统 ~~~~浅析 问题描述 大多数基于C/S模式的应用软件都存在客户端的版本更新问题.通常的解决方案是服务器端提供一个UpdateServer为每一个Client提供版本更新服务.更好一点的方案是在一个小型的局域网内部实现LocalUpdata,然后再与UpdateServer连接.解决方案一LocalUpdate: 每一个Client程序启动时,首先开始一个ServerThread并申请一个本地端口(每个Client的监听段口应一致,以便能收到Client发来的升级信息广播

Centos6.5 python升级成2.7版本出现的一些问题解决方法

由于功能及程序依赖,需要将Centos上的python从2.6升级成2.7,把碰到的一些问题记录如下: 安装好2.7后将原来的/usr/bin/python改成/usr/bin/python26,并将2.7的bin目录加入执行路径 Question1: 执行yum报No module named yum [[email protected] ~]# yum list There was a problem importing one of the Python modules required

总结:Ubuntu Python2.x和Python3.x共存,并将Python版本设成3

环境:刚重装了系统,为Ubuntu16.04目的:安装Python3.x,本例安装3.5.2步骤:1.$ python --versionpython 2.7 --->系统默认安装的版本2.到https://www.python.org/downloads/ 下载对应的版本3.安装下载的版本 tar zxvf Python-3.5.2.tgz cd Python-3.5.2 ./configure --prefix=/usr/local/python-3.5.2 #重要,指定python的安装路

把 Win 8.1 改成 Windows 2012 R2

记得当年在网上看到老外的一篇文章,讲到把 XP 改成服务器版本,好像就改一个注册表的键值. 在 Windows 2008 年代,流行过替换激活的方法,替换 token.dat 文件,系统就变成了 Vista. 如今想把 Win 8.1 也改成服务器版本,在网上找了一通一通又一通.都无果.实际上可能是没有这种需要. 闲来无事,改着玩.大体要这么几步: 1.停止 sppsvc 服务 2.替换 SPP 目录: 目录在 windir\system32\spp 和 windir\SysWOW64\spp.