【转】如何在Mac 终端升级ruby版本

原文网址:https://segmentfault.com/a/1190000003784636

rvm是什么?为什么要安装rvm呢,因为rvm可以让你拥有多个版本的Ruby,并且可以在多个版本之间自由切换。
第一步:安装rvm

$ curl -L get.rvm.io | bash -s stable
$ source ~/.rvm/scripts/rvm
  • 等待终端加载完毕,后输入:
rvm -v

如果能显示版本好则安装成功了。

第二步:安装ruby

  • 列出ruby可安装的版本信息
rvm list known
  • 安装一个ruby版本
rvm install 2.1.4

如果想设置为默认版本,可以用这条命令来完成

rvm use 2.1.4 --default
  • 查看已安装的ruby
rvm list
  • 卸载一个已安装ruby版本
rvm remove 2.1.4

第三步:更换源

  • 查看已有的源
gem source

显示会如下:

CURRENT SOURCES
http://rubygems.org/
  • 然后我们需要来修改更换源(由于国内被墙)所以要把源切换至淘宝镜像服务器 在终端执行以下命令
$ gem update --system
$ gem uninstall rubygems-update
$ gem sources -r http://rubygems.org/
$ gem sources -a http://ruby.taobao.org
时间: 08-02

【转】如何在Mac 终端升级ruby版本的相关文章

mac下升级ruby环境版本

在ios开发中会经常使用到cocoapods来管理第三方框架,在安装cocoapods的时候会涉及到ruby环境,有时候会因为版本过低会导致安装失败,本文主要讲一下如何升级ruby环境 安装rvm,rvm是可以让你拥有很多ruby版本的一个工具,具体的可以去了解一下(以下各个步骤均在terminal中实现) $ curl -L https://get.rvm.io | bash -s stable 1 期间可能会问你sudo管理员密码,这里可能需要等待一段时间后就可以成功安装好 RVM 载入rv

mac rvm升级ruby

rvm是什么?为什么要安装rvm呢,因为rvm可以让你拥有多个版本的Ruby,并且可以在多个版本之间自由切换.第一步:安装rvm $ curl -L get.rvm.io | bash -s stable $ source ~/.rvm/scripts/rvm 等待终端加载完毕,后输入: rvm -v 如果能显示版本好则安装成功了. 第二步:安装ruby 列出ruby可安装的版本信息 rvm list known 安装一个ruby版本 rvm install 2.1.4 如果想设置为默认版本,可

如何在Mac OS X上安装 Ruby运行环境

本页主要介绍如何用一条靠谱的路子快速安装 Ruby 开发环境. 系统需求 首先确定操作系统环境,不建议在 Windows 上面搞,所以你需要用: Mac OS X 以下代码区域,带有 $ 打头的表示需要在控制台(终端)下面执行(不包括 $ 符号) 步骤1 - 安装 RVM (ruby version manger ruby 版本管理) RVM 是干什么的这里就不解释了,后面你将会慢慢搞明白. $ \curl -L https://get.rvm.io | bash -s stable --rub

教大家如何在mac上用终端写代码并调试

1.   ls 2. cd Desktop/ 3. touch a.c 4. open a.c 5. cc a.c 6. ./a.out 口述一下,大致就是首先你必须打开mac终端然后: 1.显示当前目录下面的所有子目录 2.进入桌面 3.创建a.c文件 4.打开a.c文件(然后你自己在.c文件中写你需要运行的代码,之后保存关掉文件就好了) 5.编译a.c文件 6.打印编译的生成的a.out文件.就会看到终端显示结果了 版权声明:本文为博主原创文章,未经博主允许不得转载.

在 mac 上搭建 ruby 环境

一.安装系统需要的包 安装Xcode开发工具,它将帮你安装好 Unix 环境需要的开发包 打开 App Store,搜索 Xcode,第一个就是,对了,有4个多G,网速如果不大好,就请先厕所哭会儿吧,慢慢等~ 二.安装 RVM RVM 是什么?不懂?没关系,你都在看这篇文章了,说了你也不懂,如果你懂也没必要看这个,日后你慢慢且懂~ 开始进入主题: (1)打开 mac 的终端,输入一串命令:curl -L https://get.rvm.io | bash -s stable (2)载入 RVM

Mac上安装Ruby

对于新入门的开发者,如何安装 Ruby和Ruby Gems 的运行环境可能会是个问题,本页主要介绍如何用一条靠谱的路子快速安装 Ruby 开发环境.此安装方法同样适用于产品环境! 系统需求 首先确定操作系统环境,不建议在 Windows 上面搞,所以你需要用: Mac OS X 任意 Linux 发行版本(Ubuntu,CentOS, Redhat, ArchLinux ...) 强烈新手使用 Ubuntu 省掉不必要的麻烦! 以下代码区域,带有 $ 打头的表示需要在控制台(终端)下面执行(不包

iOS Mac系统下Ruby环境安装

由EasyIOS引出的一系列问题:转载的上一篇CocoaPods安装和使用教程中说明了,为什么要使用cocoapods ,但是要安装cocoapods需要Ruby环境,安装Ruby环境首先需要安装Xcode(因为xcode开发工具,他帮我们安装好Unix环境需要的开发包)然后需要安装homebrew.接下来需要安装RVM 最后安装Ruby环境 下面来说一下安装CocoaPots的顺序: Xcode->homebrew->RVM->Ruby->CocoaPats; 这篇文章之讲解如何

在Mac上安装ruby环境

CocoaPods应该是iOS最常用最有名的类库管理工具了,上述两个烦人的问题,通过cocoaPods,只需要一行命令就可以完全解决,当然前提是你必须正确设置它.重要的是,绝大部分有名的开源类库,都支持CocoaPods.所以,作为iOS程序员的我们,掌握CocoaPods的使用是必不可少的基本技能了. =========第一步  配置ruby环境============= http://www.cnblogs.com/daguo/p/4097263.html 以下代码区域,带有 $ 打头的表示

mac下的ruby环境

在mac下安装/更新ruby环境确实是挺繁琐的. 首先mac os x是自带ruby环境的, 我们通过rvm(ruby version manager)来对ruby的版本进行管理 只要执行下面2句就行了: $ gpg2 --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 $ \curl -sSL https://get.rvm.io | bash -s stable 按照一些以